AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Delphi 10.3 Rio ist da!

Ein Thema von MEissing · begonnen am 21. Nov 2018 · letzter Beitrag vom 4. Apr 2019
Antwort Antwort
Seite 30 von 32   « Erste     20282930 3132   
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
7.451 Beiträge
 
Delphi 10.3 Rio
 
#291

AW: Delphi 10.3 Rio ist da!

  Alt 17. Dez 2018, 17:00
Interessant wäre einerseits, ob das eine neue mit 10.3 Rio eingefügte Tastenkombination ist
Ich denke mal, hier geht es um eine Tastenkombination im Browser und nicht in Delphi. Das zeigt aber auch, wie weit wir hier schon vom Thema abgewichen sind.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Benutzerbild von Codehunter
Codehunter

Registriert seit: 3. Jun 2003
Ort: Thüringen
2.081 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#292

AW: Delphi 10.3 Rio ist da!

  Alt 17. Dez 2018, 17:17
Das zeigt aber auch, wie weit wir hier schon vom Thema abgewichen sind.
Ich wundere mich schon eine ganze Weile. Ist Daniel etwa schon im Urlaub? Normalerweise hätte es längst einen Rüffel gegeben.
Ich mache grundsätzlich keine Screenshots. Schießen auf Bildschirme gibt nämlich hässliche Pixelfehler und schadet der Gesundheit vom Kollegen gegenüber. I und E zu vertauschen hätte den selben negativen Effekt, würde aber eher dem Betriebsklima schaden
  Mit Zitat antworten Zitat
DualCoreCpu

Registriert seit: 11. Sep 2009
279 Beiträge
 
#293

AW: Delphi 10.3 Rio ist da!

  Alt 17. Dez 2018, 17:22
Wenn du einen guten Browser benutzt, kannst du nach dem Anmelden einfach zurück drücken und dein Text ist im Eingabefeld wieder da.

Ich werde allerdings auch nicht so schnell ausgeloggt. Normalerweise erst nach Tagen oder Wochen.
Wenn ich nicht bewusst das Häkchen in "Angemeldet" bleiben setze, reicht ein Beitrag aus, an dem ich mehr als 10 Minuten schreibe, dann will ich absenden aber das Forum zwingt mich zur Neuanmeldung. Danach ist mein Beitrag weg., alles umsonsdt geschrieben. Absolut frustrierend. Wozu dieser Sicherheitscheiß!!!????

Ich nutze MS Edge als Browser. Firefox ist mir zu ressourcenintensiv. Start braucht zu lange. Unter Knoppix hat der zu restriktive Sicherheitseinstellungen und dennoch hat einer meiner Computerfreunde, Knoppix Fan, der nichts mehr mit Windows macht, kürzlich einen ominösen Anruf bekommen, ein Porno Scam. Eine attraktive Frau wurde ihm angeboten. Hätte er seine Wohnadresse preis gegeben, hätte die nette Pornodame weitere Infos über sein Privatleben erhalten. Der nutzt ausschließlich Firefox, bzw. Iceweasel in Knoppix. Absolut sicher ist demnach nix.

Bei meinem Problem bringt es auch nix, die Seite zurück zu schalten, wenn der Anmeldebildschirm kommt. Wenn das ginge, könnte ich wenigstens per Copy & Paste meinen Beitrag sichern. Ihn kopieren, die Neunmeldung vornehmen und dann den Beitrag in ein leeres Eingabeformular einfügen. Alles abgeschaltet, was dies möglich machen würde. Wohl alles zur Sicherheit! Ich brauche diese Art von Sicherheit nicht, ich will ohne diese Einschränkungen meine Beiträge schreiben können!
  Mit Zitat antworten Zitat
CHackbart

Registriert seit: 22. Okt 2012
222 Beiträge
 
#294

AW: Delphi 10.3 Rio ist da!

  Alt 17. Dez 2018, 17:47
Der Stacktrace wäre einmal interessant.
Klar gerne,

allerdings muss ich mal gucken, wie ich das ganze so debuggen kann, dass mir die IDE nicht einfriert.

Code:
System._DbgExcNotify(-7275600,0xfda11448,0xe13ed807,0xfda11448,0xe13ed807)
System.NotifyReRaise(0xfda11448,0xe13ed807)
System._RaiseAtExcept(0xfda11448,0xe13ed807)
System.Sysutils.ErrorHandler(25,0xe13ed807)
System.ErrorAt(25,0xe13ed807)
System.Error(System.reMonitorNotLocked)
System.TMonitor.CheckOwningThread(0xf7fd8ee8)
System.TMonitor.Exit(0xf7fd8ee8)
System.TMonitor.Exit(0xf7a09fd0)
Fmx.Graphics.TCanvas.Unlock(0xe2731158)
Fmx.Graphics.TCanvas.EndScene(0xfd97c740)
Fmx.Forms.TCustomForm.PaintRects(0xf84d9208,@0xff90ffa8: {{ = { = {Left = 0, Top = 0, Right = 1280, Bottom = 728}, = {TopLeft = { = { = {V = {0, 0}}, = {X = 0, Y = 0}}}, BottomRight = { = { = {V = {1280, 728}}, = {X = 1280, Y = 728}}}}}}},0)
:E1AE6F46 __stub_in660v62__ZN3Fmx5Forms17TCommonCustomForm10PaintRectsEPKN6System5Types6TRectFEi
Fmx.Platform.Ui.Android.TFormRender.Render(0xf84a61a0)
Fmx.Platform.Ui.Android.TFormRender.run(0xf84a61a0)
:E1E7DA6A L1
:E1E7DA6A L1

Der Code den ich verwende und der dann zu der Exception führt ist der hier:

Code:
procedure TfrmMain.SetMenuVisible(Avalue: Boolean);
begin
  if Avalue then
  begin
    TAnimator.AnimateFloat(layMenu, 'Position.X', 0, 0.2, TAnimationType.In,
      TInterpolationType.Sinusoidal);
    TAnimator.AnimateFloat(tcMain, 'Position.X', layMenu.Width, 0.2,
      TAnimationType.In, TInterpolationType.Sinusoidal);
  end
  else
  begin
   TAnimator.AnimateFloat(layMenu, 'Position.X', -layMenu.Width, 0.2,
      TAnimationType.Out, TInterpolationType.Sinusoidal);
    TAnimator.AnimateFloat(tcMain, 'Position.X', 0, 0.2, TAnimationType.Out,
      TInterpolationType.Sinusoidal);
   end;
end;
ersetzt man die Animation wie folgt:

Code:
procedure TfrmMain.SetMenuVisible(Avalue: Boolean);
begin
  if Avalue then
  begin
    layMenu.Position.X := 0;
    tcMain.Position.X := layMenu.Width;
  end
  else
  begin
    layMenu.Position.X := -layMenu.Width;
    tcMain.Position.X := 0;
end;
stürzt das nicht mehr ab. Allerdings verlagert sich dann das Problem bzw. tritt halt später auf.

Christian

Geändert von CHackbart (17. Dez 2018 um 18:00 Uhr) Grund: Codeschnipsel hinzugefügt
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
7.451 Beiträge
 
Delphi 10.3 Rio
 
#295

AW: Delphi 10.3 Rio ist da!

  Alt 17. Dez 2018, 18:20
Wenn ich nicht bewusst das Häkchen in "Angemeldet" bleiben setze, reicht ein Beitrag aus, an dem ich mehr als 10 Minuten schreibe, dann will ich absenden aber das Forum zwingt mich zur Neuanmeldung. Danach ist mein Beitrag weg., alles umsonsdt geschrieben. Absolut frustrierend. Wozu dieser Sicherheitscheiß!!!????

Ich nutze MS Edge als Browser.
Ich nutze Chrome. Aber ich habe es soeben in Edge ausprobiert. Wenn ich ausgeloggt auf Antworten drücke, bekomme ich den Loginbildschirm und danach wird der Beitrag normal abgeschickt. Wenn das bei dir nicht geht, weiß ich nicht weshalb.

// EDIT:
Bezüglich des Absturzes:
Ein neuer Beitrag dafür wäre sinnvoll. Für mich sieht das TFormRender.run so aus als ob das in einem eigenen Thread läuft. Ich schaue mal, ob mir da etwas auffällt...
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!

Geändert von jaenicke (17. Dez 2018 um 18:25 Uhr)
  Mit Zitat antworten Zitat
CHackbart

Registriert seit: 22. Okt 2012
222 Beiträge
 
#296

AW: Delphi 10.3 Rio ist da!

  Alt 17. Dez 2018, 18:32
Ja ich denke auch das macht Sinn. Bei der Gelegenheit werde ich mal eine Beispielanwendung mit Code erstellen. Vielleicht kriege ich das reproduziert. Dann poste ich den Code mal hier im Forum.

Christian
  Mit Zitat antworten Zitat
Daniel
(Administrator)

Registriert seit: 30. Mai 2002
Ort: Hamburg
15.254 Beiträge
 
Delphi 10.3 Rio
 
#297

AW: Delphi 10.3 Rio ist da!

  Alt 17. Dez 2018, 19:24
Ich wundere mich schon eine ganze Weile. Ist Daniel etwa schon im Urlaub? Normalerweise hätte es längst einen Rüffel gegeben.
Sorry, ich war erst auf Seite 12 beim Lesen.
So, nun habe ich 18 Seiten übersprungen und muss improvisieren (hoffentlich merkt das keiner):
So, Rüffel. An alle.


Es ging hier ursprünglich um Neuigkeiten, die in Zusammenhang mit der neuen Delphi-Version stehen und von generellem Interesse sind.
Wenn Ihr individuelle Fehler findet, macht dafür bitte neue Themen auf, in denen dann Reproduzierbarkeit etc. diskutiert werden können.


Und wenn Ihr hier - gefühlt - zu schnell ausgeloggt werdet, dann hängt dies üblicherweise mit zu restriktiven Cookie-Einstellungen Eurerseits zusammen. Ich nutze im Büro ebenfalls den Edge-Browser und werde regelmäßig immer wieder automatisch eingeloggt, meistens sogar transparent für mich.
Daniel R. Wolf
Admin Delphi-PRAXiS
mit Grüßen aus Hamburg
  Mit Zitat antworten Zitat
Benutzerbild von Codehunter
Codehunter

Registriert seit: 3. Jun 2003
Ort: Thüringen
2.081 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#298

AW: Delphi 10.3 Rio ist da!

  Alt 23. Dez 2018, 15:41
Und wenn Ihr hier - gefühlt - zu schnell ausgeloggt werdet, dann hängt dies üblicherweise mit zu restriktiven Cookie-Einstellungen Eurerseits zusammen. Ich nutze im Büro ebenfalls den Edge-Browser und werde regelmäßig immer wieder automatisch eingeloggt, meistens sogar transparent für mich.
Kann ich bestätigen. Mit Ausnahme des VBSEO-Cookies haben alle DP-Cookies eine Laufzeit von 6 Monaten. Wenn man zu oft ausgeloggt wird könnte das auch an übereifrigen Plugins wie z.B. Ghostery oder uBlock liegen (Ausnahmeliste pflegen!). Und Delphi Rio ist mit Sicherheit auch nicht dran Schuld. Ach ja: Rüffel an Daniel wegen des OT (Man da musste ich 15 Jahre drauf warten das mal sagen zu dürfen)

Frohes Fest @Alle!
Ich mache grundsätzlich keine Screenshots. Schießen auf Bildschirme gibt nämlich hässliche Pixelfehler und schadet der Gesundheit vom Kollegen gegenüber. I und E zu vertauschen hätte den selben negativen Effekt, würde aber eher dem Betriebsklima schaden
  Mit Zitat antworten Zitat
Satyr

Registriert seit: 8. Feb 2012
Ort: Essen
256 Beiträge
 
Delphi 2007 Professional
 
#299

AW: Delphi 10.3 Rio ist da!

  Alt 25. Dez 2018, 00:23
Hallo und frohe Weihnachten

Aus Neugier habe ich mir die Community Version von Rio installiert.
Installation ging fix, ohne Probleme und auf den ersten Blick sieht es sehr gut aus, für meine Zwecke.


Auf den zweiten Blick bekomme ich Android Projekte nicht gepackt weil immer android.jar fehlt (Compilieren geht vorher problemlos). Das bekomme ich aber noch eingestellt.

Viel wichtigeres Problem... die IDE zeigt mir bei Hints keinen Text an. nur ein weißes, leeres Kästchen.
Nicht im Projekt, da funktioniert es. Im Objektinspektor auch.
In der Komponentenpalette und allem anderen leider nicht. Sehr merkwürdig.
  Mit Zitat antworten Zitat
Pfaffe

Registriert seit: 29. Jan 2009
220 Beiträge
 
Delphi 10.3 Rio
 
#300

AW: Delphi 10.3 Rio ist da!

  Alt 25. Dez 2018, 07:08
01:23 Da sollte man aber in der Christmette sein

Bzgl. Hint in der Komponentenpalette, bei mir funktioniert es, habe allerdings die ersten Patches schon eingespielt.
Siehe https://cc.embarcadero.com/myreg
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 22:19 Uhr.
Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf