AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Delphi spinnt

Ein Thema von Pflaumi · begonnen am 30. Mai 2019 · letzter Beitrag vom 4. Jun 2019
Antwort Antwort
Seite 1 von 3  1 23   
Benutzerbild von Pflaumi
Pflaumi

Registriert seit: 21. Mai 2019
Ort: Reichenschwand
31 Beiträge
 
Delphi 7 Enterprise
 
#1

Delphi spinnt

  Alt 30. Mai 2019, 14:12
Hallo,
seit ein paar Tagen spinnt mein Delphi-Editor.
Es gab 2 Probleme:
1. Wenn man eine neue Zeile anfangen wollt (Return), ist der Cursor einfach in die Zeile darunter
gerutscht, anstatt dass er eine neue Zeile angefangen hat.
2. Wenn man mitten in einer Zeile etwas ergenzen wollte, hat der Editor dass neue Zeichen durch
das danachstehende ersetzt.
Dieses Problem wollte ich lößen, indem ich einen anderen Editor benutzt habe (Notepad++).
Bald darauf kam von Delphi dann, dass er die Komponenten nicht versteht.
Code:
type
  TForm1 = class(TForm)
     Image1: TImage;
     procedure FormCreate(Sender: TObject);
  private
     { Private-Deklarationen }
  public
     { Public-Deklarationen }
  end;

procedure FormCreate(Sender: TObject);
begin
   Image1.Show;
end;
Dann kam immer diese Fehlermeldung: '[Fehler] Unit1.pas(40): Undefinierter Bezeichner: 'Image1''

Jetzt kann ich mit Delphi eigentlich nichts mehr machen

Weiß irgentjemand wie ich wieder normal mit Delphi programmieren kann?
Die einzige Methode das wieder hinzubekommen wäre, dass Programm deinstallieren und dann wieder neu installieren.


Ich freue mich über Hilfe!
Felix
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)
Online

Registriert seit: 29. Mai 2002
37.300 Beiträge
 
Delphi 2006 Professional
 
#2

AW: Delphi spinnt

  Alt 30. Mai 2019, 14:20
Überschreibmodus aktiviert?
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Delphi.Narium

Registriert seit: 27. Nov 2017
1.093 Beiträge
 
Delphi 7 Professional
 
#3

AW: Delphi spinnt

  Alt 30. Mai 2019, 14:31
Hallo,
seit ein paar Tagen spinnt mein Delphi-Editor.
Es gab 2 Probleme:
1. Wenn man eine neue Zeile anfangen wollt (Return), ist der Cursor einfach in die Zeile darunter
gerutscht, anstatt dass er eine neue Zeile angefangen hat.
2. Wenn man mitten in einer Zeile etwas ergenzen wollte, hat der Editor dass neue Zeichen durch
das danachstehende ersetzt.
Dieses Problem wollte ich lößen, indem ich einen anderen Editor benutzt habe (Notepad++).
Bald darauf kam von Delphi dann, dass er die Komponenten nicht versteht.
Code:
type
  TForm1 = class(TForm)
     Image1: TImage;
     procedure FormCreate(Sender: TObject);
  private
     { Private-Deklarationen }
  public
     { Public-Deklarationen }
  end;

procedure FormCreate(Sender: TObject);
begin
   Image1.Show;
end;
Dann kam immer diese Fehlermeldung: '[Fehler] Unit1.pas(40): Undefinierter Bezeichner: 'Image1''

Jetzt kann ich mit Delphi eigentlich nichts mehr machen

Weiß irgentjemand wie ich wieder normal mit Delphi programmieren kann?
Die einzige Methode das wieder hinzubekommen wäre, dass Programm deinstallieren und dann wieder neu installieren.


Ich freue mich über Hilfe!
Delphi kommt (vermutlich) nicht mit dem fehlerhaften Quelltext zurecht.
Delphi-Quellcode:
type
  TForm1 = class(TForm)
     Image1: TImage;
     procedure FormCreate(Sender: TObject);
  private
     { Private-Deklarationen }
  public
     { Public-Deklarationen }
  end;

// procedure FormCreate(Sender: TObject); // <-- das ist falsch.
procedure TForm1.FormCreate(Sender: TObject); // <-- da fehlte das TForm1. vor dem FormCreate.
begin
  Image1.Show;
end;
  Mit Zitat antworten Zitat
Benutzerbild von Pflaumi
Pflaumi

Registriert seit: 21. Mai 2019
Ort: Reichenschwand
31 Beiträge
 
Delphi 7 Enterprise
 
#4

AW: Delphi spinnt

  Alt 30. Mai 2019, 14:43
Entschuldigung,
dass mit dem TForm.FormCreate war falsch abgetippt (nicht kopiert).
Felix
  Mit Zitat antworten Zitat
Aviator

Registriert seit: 3. Jun 2010
1.424 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#5

AW: Delphi spinnt

  Alt 30. Mai 2019, 14:44
Also ich behaupte auch mal, dass du auf die Einfg (Einfügen) Taste über den Pfeiltasten gekommen bist. Dann schaltet der Editor in den "Überschreiben" Modus um. Das kannst du auch sehen, indem du dir die Statusleiste unten anschaust. Dort steht dann "Überschreiben" statt "Einfügen".

Allerdings sollte sich das nach einem Delphi Neustart automatisch erledigen.
  Mit Zitat antworten Zitat
Benutzerbild von Pflaumi
Pflaumi

Registriert seit: 21. Mai 2019
Ort: Reichenschwand
31 Beiträge
 
Delphi 7 Enterprise
 
#6

AW: Delphi spinnt

  Alt 2. Jun 2019, 13:21
Danke für die Tipps,
inzwischen läuft alles wieder perfekt!
Das mit dem Überschreibmodus war das Problem.
Vielen Dank!
Felix

Geändert von Pflaumi ( 2. Jun 2019 um 14:58 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)
Online

Registriert seit: 29. Mai 2002
37.300 Beiträge
 
Delphi 2006 Professional
 
#7

AW: Delphi spinnt

  Alt 2. Jun 2019, 18:45
Und wie hast du es gelöst?
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Hobbycoder

Registriert seit: 22. Feb 2017
673 Beiträge
 
#8

AW: Delphi spinnt

  Alt 3. Jun 2019, 07:09
Ich habe das Problem auch „ab und zu“ mal.
In einigen Fällen reicht es die „Einf“-Taste einfach zu drücken (man ist wohl versehentlich mal draufgekommen). Aber oft funktioniert das nicht und es hilft nur ein Delphi-Neustart.

Ob ich wirklich sooft versehentlich auf die „Einf“-Taste komme kann ich schwer sagen. Ich meine zwar nicht, aber man kann sich bei sowas auch schnell täuschen. (Eigentlich ist die Taste für mich eher überflüssig)
Gruß Hobbycoder
Alle sagten: "Das geht nicht.". Dann kam einer, der wusste das nicht, und hat's einfach gemacht.
  Mit Zitat antworten Zitat
hoika

Registriert seit: 5. Jul 2006
Ort: Magdeburg
7.216 Beiträge
 
Delphi XE4 Professional
 
#9

AW: Delphi spinnt

  Alt 3. Jun 2019, 07:17
Hallo,
Zitat:
Und wie hast Du es gelöst?
Hatte er doch schon beschrieben .. ?

Zitat:
Das mit dem Überschreibmodus war das Problem.
Heiko
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)
Online

Registriert seit: 29. Mai 2002
37.300 Beiträge
 
Delphi 2006 Professional
 
#10

AW: Delphi spinnt

  Alt 3. Jun 2019, 08:56
Das war der Grund, aber wie hat er es gelöst? Der externe Editor scheint ja nicht im Überscheibmodus gewesen zu sein. Also kann es eigentlich nicht an der Einfg-Taste gelegen haben, weil die wirkt sich ja global aus. Oder nur, wenn das Fenster aktiv ist? Schalte ich also vorher in den Überschreinmodus, wirkt sich das nicht auf neue Fenster/Programme aus?

(Ich bin am Tablet und kann es gerade nicht selber testen.)
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 10:59 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf