AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken RAD Server Installation Windows

RAD Server Installation Windows

Ein Thema von wjjw · begonnen am 30. Mai 2020 · letzter Beitrag vom 24. Apr 2021
Antwort Antwort
Seite 1 von 3  1 23   
Benutzerbild von wjjw
wjjw

Registriert seit: 3. Aug 2017
Ort: Wiener Neustadt, Österreich
64 Beiträge
 
Delphi 10.4 Sydney
 
#1

RAD Server Installation Windows

  Alt 30. Mai 2020, 18:20
Datenbank: RAD Server • Version: 10.3.3 • Zugriff über: http
Hallo,
versuche den RAD Server auf einem Windows 2019 Server zu installieren (IIS 10).
Laut Beschreibung sollte das ja ganz einfach klappen. Jedoch nicht so bei mir. Habe alles nach Anleitung (docwiki) gemacht.

Mein Problem:
Beim Aufruf der url will er die DLL herunterladen anstelle sie auszuführen.
Also beim Aufruf von http://localhost/radconsole
Support verweist mich immer auf die docwiki. Aktuelle Videos hab ich auch nicht wirklich gefunden.

Hat jemand Erfahrungen damit bzw. schon erfolgreich installiert?
Werner Weiß
--
Werner
  Mit Zitat antworten Zitat
Benutzerbild von MEissing
MEissing

Registriert seit: 19. Jan 2005
Ort: Egelsbach
1.183 Beiträge
 
Delphi 11 Alexandria
 
#2

AW: RAD Server Installation Windows

  Alt 30. Mai 2020, 23:03
DLLs müssen zur Ausführung aktiviert werden. Steht auch so im Docwiki

Ist eine häufige Frage in der „IIS-Welt“

https://stackoverflow.com/questions/...-on-windows-10

CGI / ISAPI muss installiert sein.
Matthias Eißing
cu://Matthias.Eißing.de [Embarcadero]
Kein Support per PN
  Mit Zitat antworten Zitat
Benutzerbild von wjjw
wjjw

Registriert seit: 3. Aug 2017
Ort: Wiener Neustadt, Österreich
64 Beiträge
 
Delphi 10.4 Sydney
 
#3

AW: RAD Server Installation Windows

  Alt 31. Mai 2020, 19:58
Nach stundenlangem Lesen von diversen Foren bin ich auf keine "neue" Lösung gestossen.
Jedoch habe ich jetzt die 32-Bit Version installiert, und siehe da, die DLL wird nicht mehr heruntergeladen.
Habe auch eine eigene ISAPI-Datei geschrieben, die auch problemlos funktioniert (32-bit) -> bei 64-bit gleiches Problem mit Download....
Aber solange alles in 32-Bit auf meinem 64-Bit OS läuft ist das ok.

Nur:
Ich bekomme beim EMSServer.dll und EMSConsole.dll nur eine Seite die "LOADING..." anzeigt.
Wenn ich die Entwicklerversion "EMSDevConsole.exe" starte (also ohne IIS), funktioniert sie ohne Probleme.

Was nun??
Werner Weiß
--
Werner
  Mit Zitat antworten Zitat
Benutzerbild von MEissing
MEissing

Registriert seit: 19. Jan 2005
Ort: Egelsbach
1.183 Beiträge
 
Delphi 11 Alexandria
 
#4

AW: RAD Server Installation Windows

  Alt 1. Jun 2020, 07:16
Das passiert, wenn man die DE Dateien aus extjs und webresources von C:\Program Files (x86)\Embarcadero\Studio\2x.0\ObjRepos\de\EMS vergisst...Aus EN kopieren.
Matthias Eißing
cu://Matthias.Eißing.de [Embarcadero]
Kein Support per PN
  Mit Zitat antworten Zitat
Benutzerbild von wjjw
wjjw

Registriert seit: 3. Aug 2017
Ort: Wiener Neustadt, Österreich
64 Beiträge
 
Delphi 10.4 Sydney
 
#5

AW: RAD Server Installation Windows

  Alt 2. Jun 2020, 18:50
Folgendes vom Support bekommen:
"Please be aware that IIS 10 is not supported with Rad Server. IIS 7 is the only version of IIS certified to work with Rad Server at this time.".

Ich habe einen Windows Server 2019 - da ist natürlich der IIS 10 installiert.
Jetzt muss ich IIS 7 installieren??
IIS 7 wurde in Windows Vista (2007) und Windows Server 2008 integriert. Danach ist schon "sehr viel Wasser geflossen"... 13 Jahre später...
Werner Weiß
--
Werner
  Mit Zitat antworten Zitat
Benutzerbild von MEissing
MEissing

Registriert seit: 19. Jan 2005
Ort: Egelsbach
1.183 Beiträge
 
Delphi 11 Alexandria
 
#6

AW: RAD Server Installation Windows

  Alt 3. Jun 2020, 10:57
Offiziell ist die eine Sache (ja... ich habe das intern eskaliert); inoffiziell geht das aber problemlos auch auf IIS 10

Man muss nur beachten:
(Ich würde alles auf 64-Bit laufen lassen, weil der IIS auch 64 bittig ist; also auch die eigenen BPLs in 64 Bit kompilieren und die 64-Bit BPLs/DLLs vom RAD Server nutzen)
- ISAPI (und CGI) installieren
- ISAPI und CGI-Einschränkungen:
Featureeinstellungen bearbeiten
[X] Nicht angegebene ISAPI-Module zulassen
- Die EMSSERVER.INI lieber dreinmal checken (und in der Registry überprüfen, welche genommen wird):
HKEY_LOCAL_MACHINE\SOFTWARE\Embarcadero\EMS
Matthias Eißing
cu://Matthias.Eißing.de [Embarcadero]
Kein Support per PN
  Mit Zitat antworten Zitat
Benutzerbild von twein
twein

Registriert seit: 2. Jan 2004
Ort: Düsseldorf
49 Beiträge
 
Delphi 10.3 Rio
 
#7

AW: RAD Server Installation Windows

  Alt 16. Jun 2020, 17:37
Hallo zusammen,


ich bekomme immer einen Fehler!
Den gleichen fehler bekomme ich auch bei einer Linux-Installation.

Die ausführbaren Dateien funktionieren!

description "EMS license not found. To resolve this issue, install an instance of Interbase with an EMS license and configure emsserver.ini to connect to the licensed instance. Error: Interbase instance does not have EMS server license. Product: \"\""
Thomas
  Mit Zitat antworten Zitat
Benutzerbild von twein
twein

Registriert seit: 2. Jan 2004
Ort: Düsseldorf
49 Beiträge
 
Delphi 10.3 Rio
 
#8

AW: RAD Server Installation Windows

  Alt 16. Jun 2020, 17:51
Die EMSSERVER.INI lieber dreinmal checken (und in der Registry überprüfen, welche genommen wird):
HKEY_LOCAL_MACHINE\SOFTWARE\Embarcadero\EMS
Ich habe keinen Eintrag: "HKEY_LOCAL_MACHINE\SOFTWARE\Embarcadero\EMS"

aber Einträge unter "HKEY_CURRENT_USER\SOFTWARE\Embarcadero\EMS"
Thomas
  Mit Zitat antworten Zitat
Benutzerbild von MEissing
MEissing

Registriert seit: 19. Jan 2005
Ort: Egelsbach
1.183 Beiträge
 
Delphi 11 Alexandria
 
#9

AW: RAD Server Installation Windows

  Alt 16. Jun 2020, 18:01
Hallo zusammen,


ich bekomme immer einen Fehler!
Den gleichen fehler bekomme ich auch bei einer Linux-Installation.

Die ausführbaren Dateien funktionieren!

description "EMS license not found. To resolve this issue, install an instance of Interbase with an EMS license and configure emsserver.ini to connect to the licensed instance. Error: Interbase instance does not have EMS server license. Product: \"\""
Schick mir mal die Seriennummer des RAD Servers als PN

Und die Regsitry Einträge können da sein... müssen aber nicht.
Matthias Eißing
cu://Matthias.Eißing.de [Embarcadero]
Kein Support per PN
  Mit Zitat antworten Zitat
Benutzerbild von MEissing
MEissing

Registriert seit: 19. Jan 2005
Ort: Egelsbach
1.183 Beiträge
 
Delphi 11 Alexandria
 
#10

AW: RAD Server Installation Windows

  Alt 16. Jun 2020, 21:36
Mal was grundsätzliches:

RAD Server gibt es in zwei verschiedenen Geschmacksrichtungen: Development-Server und Produktiv-Server

Der Development-Server läuft praktisch sofort, wenn man RAD Studio (mit InterBase) installiert hat. Anfängliche Erstkonfiguration mit "Weiter" -> "Weiter" durchlaufen: Fertig
Der Produktiv-Server, als Aufsatz für IIS und/oder Apache, muss lizensiert werden (da hat's bei "twein" gefehlt / per PN). Das Ganze funktioniert über die Lizenzierung des eingebetteten InterBase'.

Die Installationsdateien für den Produktivserver bekommt man über GetIt in der IDE. Das ist dann InterBase + notwendige Grundpackages. Eigene Packages und benötigte BPLs muss man dann selber deployen/kopieren. Und das eigene Package in der EMSServer.INI konfigurieren.

Wichtig: IIS in neueren Version kann nicht direkt mit DLLs und schon gar nicht mit 32-Bit DLLs umgehen. Enable32Bit DLLs muss man konfigurieren. ISAPI und CGI nachinstallieren und das Ausführen der DLLs einschalten.

(Ich zeige das auch mal mit einem IIS 10 auf der diesjährigen EKON in Düsseldorf)
Matthias Eißing
cu://Matthias.Eißing.de [Embarcadero]
Kein Support per PN
  Mit Zitat antworten Zitat
Antwort Antwort
Seite 1 von 3  1 23   

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 06:27 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf