AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Ctrl-# funktioniert nicht (immer)

Ein Thema von Uwe Raabe · begonnen am 7. Aug 2020 · letzter Beitrag vom 19. Aug 2020
Antwort Antwort
Seite 2 von 5     12 34     Letzte » 
Benmik

Registriert seit: 11. Apr 2009
437 Beiträge
 
Delphi 10.3 Rio
 
#11

AW: Ctrl-# funktioniert nicht (immer)

  Alt 7. Aug 2020, 20:50
"Befolgend dies ward der Tabant,
ein völlig deutscher Gegenstand."

(Christian Morgenstern)
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.766 Beiträge
 
Delphi 10.1 Berlin Professional
 
#12

AW: Ctrl-# funktioniert nicht (immer)

  Alt 8. Aug 2020, 08:44
Moin...
Zitat:
Meine Vermutung ist: Das reine Öffnen des Popup-Menüs genügt um die Funktionalität wiederherzustellen
...nicht nur. Bei mir reicht auch ein beherztes Klicken auf "Einfügen" (Tastatur) und wieder zurück.
Zitat:
Das ist der entsprechende Key-Code für das Englische Tastatur-Layout
...der Code der "Einfügen" Taste ist doch überall gleich? Oder? (nicht kontrolliert ) Dann wäre es doch ein "weltliches" Problem.
Zitat:
Meine Idee basiert auf der Annahme, dass ein TAction.OnUpdate
...da ist TAction nicht im Spiel.

Geändert von haentschman ( 8. Aug 2020 um 09:22 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
8.451 Beiträge
 
Delphi 10.4 Sydney
 
#13

AW: Ctrl-# funktioniert nicht (immer)

  Alt 8. Aug 2020, 09:48
...nicht nur. Bei mir reicht auch ein beherztes Klicken auf "Einfügen" (Tastatur) und wieder zurück.
Guter Hinweis. Widerspricht aber immer noch nicht meiner Vermutung. Das Umschalten des Mode könnte natürlich auch dafür sorgen, daß die ToggleComment-Action wieder aktiv wird.

...der Code der "Einfügen" Taste ist doch überall gleich? Oder? (nicht kontrolliert ) Dann wäre es doch ein "weltliches" Problem.
Die Delphi-Hilfe nennt für die Kommentar-Umschalten Funktion lediglich das Strg-/. Da das auf einer Deutschen Tastatur aber nicht so leicht zu erreichen ist wie auf einer Englischen, gibt es alternativ noch das Ctrl-#.

...da ist TAction nicht im Spiel.
Woher willst du das wissen? Ich bin mir sogar ziemlich sicher, daß das Kommentar-Umschalten über eine Action realisiert wird. Ich kann dir sogar sagen wie die heißt: ecToggleComment
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.766 Beiträge
 
Delphi 10.1 Berlin Professional
 
#14

AW: Ctrl-# funktioniert nicht (immer)

  Alt 8. Aug 2020, 10:10
...war nur eine Vermutung. Kein Menü, nur Tastatur.
  Mit Zitat antworten Zitat
einbeliebigername

Registriert seit: 24. Aug 2004
130 Beiträge
 
Delphi XE8 Professional
 
#15

AW: Ctrl-# funktioniert nicht (immer)

  Alt 8. Aug 2020, 10:30
Hallo,

ich kann unter 10.1 bestätigen, dass das aufmachen und gleich wieder schließen des Kontextmenüs reicht, um Strg+# wieder Funktionsfähige zu bekommen.

Witzig ist aber, dass Strg+/ (Nummerblock) dagegen fast immer funktioniert und das Selbe macht.
Das ist der entsprechende Key-Code für das Englische Tastatur-Layout.
Das sehe ich anders, da die Funktionsweisen der beiden sich unterscheiden. Wenn nichts markiert ist, schalten beide die Kommentierung der Zeile unterm Cursor um. Bei Strg+# bleibt der Cursor in der Zeile und Strg+/[Zehnerblock] setzt den Cursor eine Zeile nach unten.

Ich glaube das Problem ist größer.

Ich wage zu behaupten, wenn das Problem einmal aufgetreten ist, dass dann alle Tastenkombinationen des Kontextmenüs Buggy sind. Auch Refactoring -> Umbenennen alias Umsch+Strg+E hat Probleme. In Unit A Rechtsklick -> Refactoring -> Umbenennen und im Dialog abbrechen drücken. Auf Unit B wechseln und Umsch+Strg+E drücken. Er will dann den Bezeichner, welcher zuletzt in Unit A unterm Cursor befand, umbenennen. Auch das lässt sich mit Öffnen und Schließen des Kontextmenüs erst mal wieder lösen. Aber im Gegensatz zu Strg+#, welches bei weiteren Unit-Wechseln erst mal wieder funktioniert, erholt sich Umsch+Strg+E nicht. Man muss dann nach jedem Unit-Wechsel erst einmal das Kontextmenü aufmachen, damit Umsch+Strg+E funktioniert.
Mit freundlichen Grüßen, einbeliebigername.
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
1.567 Beiträge
 
Delphi 10.3 Rio
 
#16

AW: Ctrl-# funktioniert nicht (immer)

  Alt 8. Aug 2020, 10:54
Moin...
Zitat:
Meine Vermutung ist: Das reine Öffnen des Popup-Menüs genügt um die Funktionalität wiederherzustellen
...nicht nur. Bei mir reicht auch ein beherztes Klicken auf "Einfügen" (Tastatur) und wieder zurück.
Klicken auf Einfügen bedeutet was genau?
  1. Drücken der Taste Einfg (EN: Ins)
  2. Drücken der Tastenkombination Strg-V
  3. Anklicken eines Einfügen Kontext/Menüpunktes mit der Maus (deiner Formulierung nach eher nicht)

Ich frage so dusselig um den QP report möglichst präzise ergänzen zu können, damit wir möglichst schnell möglichst
hohe Chancen auf einen fix haben.

Grüße
TurboMagic
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
8.451 Beiträge
 
Delphi 10.4 Sydney
 
#17

AW: Ctrl-# funktioniert nicht (immer)

  Alt 8. Aug 2020, 10:59
Das sehe ich anders, da die Funktionsweisen der beiden sich unterscheiden. Wenn nichts markiert ist, schalten beide die Kommentierung der Zeile unterm Cursor um. Bei Strg+# bleibt der Cursor in der Zeile und Strg+/[Zehnerblock] setzt den Cursor eine Zeile nach unten.
Gut erkannt

Interessant ist auch: Wenn man das Englische Tastaturlayout verwendet, dann wirkt der entsprechende Menüpunkt genauso.


Ich wage zu behaupten, wenn das Problem einmal aufgetreten ist, dass dann alle Tastenkombinationen des Kontextmenüs Buggy sind. Auch Refactoring -> Umbenennen alias Umsch+Strg+E hat Probleme. In Unit A Rechtsklick -> Refactoring -> Umbenennen und im Dialog abbrechen drücken. Auf Unit B wechseln und Umsch+Strg+E drücken. Er will dann den Bezeichner, welcher zuletzt in Unit A unterm Cursor befand, umbenennen. Auch das lässt sich mit Öffnen und Schließen des Kontextmenüs erst mal wieder lösen. Aber im Gegensatz zu Strg+#, welches bei weiteren Unit-Wechseln erst mal wieder funktioniert, erholt sich Umsch+Strg+E nicht. Man muss dann nach jedem Unit-Wechsel erst einmal das Kontextmenü aufmachen, damit Umsch+Strg+E funktioniert.
Vielleicht könntest du das ale Ergänzung in den QP aufnehmen?
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.766 Beiträge
 
Delphi 10.1 Berlin Professional
 
#18

AW: Ctrl-# funktioniert nicht (immer)

  Alt 8. Aug 2020, 11:00
Zitat:
Drücken der Taste Einfg (EN: Ins)
...genau diese.
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
1.567 Beiträge
 
Delphi 10.3 Rio
 
#19

AW: Ctrl-# funktioniert nicht (immer)

  Alt 8. Aug 2020, 11:01
Hallo,

ich kann unter 10.1 bestätigen, dass das aufmachen und gleich wieder schließen des Kontextmenüs reicht, um Strg+# wieder Funktionsfähige zu bekommen.

Ich glaube das Problem ist größer.

Ich wage zu behaupten, wenn das Problem einmal aufgetreten ist, dass dann alle Tastenkombinationen des Kontextmenüs Buggy sind. Auch Refactoring -> Umbenennen alias Umsch+Strg+E hat Probleme. In Unit A Rechtsklick -> Refactoring -> Umbenennen und im Dialog abbrechen drücken. Auf Unit B wechseln und Umsch+Strg+E drücken. Er will dann den Bezeichner, welcher zuletzt in Unit A unterm Cursor befand, umbenennen. Auch das lässt sich mit Öffnen und Schließen des Kontextmenüs erst mal wieder lösen. Aber im Gegensatz zu Strg+#, welches bei weiteren Unit-Wechseln erst mal wieder funktioniert, erholt sich Umsch+Strg+E nicht. Man muss dann nach jedem Unit-Wechsel erst einmal das Kontextmenü aufmachen, damit Umsch+Strg+E funktioniert.
Hast du schon mal geschaut ob diese rename refactoring Probleme schon in QP (quality.embarcadero.com) erfasst sind?
Falls nicht bitte erfassen und die Report Nummer hier melden.
Einziges Problem bei allen diesen Problemstellungen: die treten sporadisch auf, was ein Reproduzieren erschwert.
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
1.567 Beiträge
 
Delphi 10.3 Rio
 
#20

AW: Ctrl-# funktioniert nicht (immer)

  Alt 8. Aug 2020, 11:01
Zitat:
Drücken der Taste Einfg (EN: Ins)
...genau diese.
Danke für die schnelle Rückmeldung!
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 20:25 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf