AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Ctrl-# funktioniert nicht (immer)

Ein Thema von Uwe Raabe · begonnen am 7. Aug 2020 · letzter Beitrag vom 19. Aug 2020
Antwort Antwort
Seite 1 von 5  1 23     Letzte » 
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
8.451 Beiträge
 
Delphi 10.4 Sydney
 
#1

Ctrl-# funktioniert nicht (immer)

  Alt 7. Aug 2020, 13:51
Es gibt da gerade Bestrebungen das sporadische Nicht-Funktionieren von Ctrl-# in den Griff zu bekommen. Das Problem ist in diese QP-Eintrag beschrieben: Key combination Ctrl+# (comment) does not work.

Meine Vermutung ist: Das reine Öffnen des Popup-Menüs genügt um die Funktionalität wiederherzustellen. Ein Auslösen der Menü-Funktion ist dazu gar nicht nötig. Es sollte also reichen, das Kontextmenü aufzurufen, wieder zu schließen und Ctrl-# nochmal zu versuchen.

Jetzt ist es aber nicht einfach, das Problem zu provozieren, da wir bisher nicht wissen wodurch es ausgelöst wird. Aber es sollte dem Einen oder Anderen vielleicht mal über den Weg laufen und dann wäre es schön, wenn ihr kurz testen könntet, ob meine Vermutung noch stimmt oder nicht. Die jeweiligen Ergebnisse könnt ihr dann hier posten.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Redeemer

Registriert seit: 19. Jan 2009
Ort: Kirchlinteln (LK Verden)
767 Beiträge
 
Delphi 2009 Professional
 
#2

AW: Ctrl-# funktioniert nicht (immer)

  Alt 7. Aug 2020, 14:57
Klingt so, als wäre die Action einfach grundlos deaktiviert, weil nicht zuverlässig überprüft wird, ob sie wieder aktiviert werden muss.

So ein Bug existiert auch anderswo seit gefühlt BDS 1 oder noch länger und bis heute:
* Formular im Designer selbst auswählen, Rechtsklick machen, das Untermenü "Element" öffnen (Rechtsklick allein reicht nicht): "Nach vorne/hinten" ist deaktiviert. Klar, denn das Formular kann das nicht.
* Im Fenster "Struktur" ein Element auswählen und darauf rechtsklicken: Menü ist immer noch deaktiviert.
Geht auch andersrum: Erst im Designer etwas anderes als die Form auswählen und Rechtsklick machen, Untermenü "Element" öffnen. Dann die Form unter "Struktur" auswählen. Besagte Funktionen stehen sinnloserweise zur Verfügung.
Janni
2005 PE, 2009 PA, XE2 PA
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
1.567 Beiträge
 
Delphi 10.3 Rio
 
#3

AW: Ctrl-# funktioniert nicht (immer)

  Alt 7. Aug 2020, 15:04
Hast du mal geschaut, ob das schon in QP erfasst ist und es falls nicht bitte erfasst?
  Mit Zitat antworten Zitat
Benmik

Registriert seit: 11. Apr 2009
437 Beiträge
 
Delphi 10.3 Rio
 
#4

AW: Ctrl-# funktioniert nicht (immer)

  Alt 7. Aug 2020, 15:06
Ouh, das tritt bei mir völlig zuverlässig auf, nach längerem Arbeiten. Mit Popup-Menü ist Rechtsklick in den Editor gemeint? Wäre ja toll, wenn das so einfach ginge.

Da wir dabei sind, auch bei euch müsste es doch auftreten, dass die überwachten Ausdrücke im Debugger ausgegraut und nicht mehr erreichbar sind. Gibt's da auch so etwas Einfaches?
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
1.567 Beiträge
 
Delphi 10.3 Rio
 
#5

AW: Ctrl-# funktioniert nicht (immer)

  Alt 7. Aug 2020, 15:39
Lass' uns mal erst an der einen Sache arbeiten!

Bei mir trat das Strg-# Problem auch zuverlässig auf, bis ich Uwe's neue Idee mit rechtsklick
im Editor zum Kontextmenü Aufrufen testen wollte. Da trat's dann vorher nicht mehr auf

=> kannst du das mal testen und bitte Rückmeldung geben ob das alleinige Öffnen des Kontextmenüs
schon was bringt? Ich hatte dann immer mit der Maus den "Kommentar Umschalten" Menüpunkt betätigt
und ab da das Problem für die IDE Sitzung abgestellt gehabt. Aber Uwe will ja getestet haben,
ob das alleinige Öffnen des Kontextmenüs dafür reicht.
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
8.451 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: Ctrl-# funktioniert nicht (immer)

  Alt 7. Aug 2020, 16:03
Hast du mal geschaut, ob das schon in QP erfasst ist und es falls nicht bitte erfasst?
Der QP wird aktuell mangels Reproduzierbarkeit nicht geöffnet - kann ich verstehen.

Meine Idee basiert auf der Annahme, dass ein TAction.OnUpdate den Shortcut wieder ins Rennen bringt. Mit dem Hinweis könnten wir den Bug vielleicht doch noch im System pushen. Ich würde es aber nicht ins QP übernehmen, wenn es eine Sackgasse ist.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
TurboMagic

Registriert seit: 28. Feb 2016
Ort: Nordost Baden-Württemberg
1.567 Beiträge
 
Delphi 10.3 Rio
 
#7

AW: Ctrl-# funktioniert nicht (immer)

  Alt 7. Aug 2020, 16:18
Hallo Uwe,

da hab' ich mich einerseits unglücklich ausgedrückt und du andererseits missverstanden was ich meinte.
Die Strg-# Sache ist mir bewußt (ich kenne den Report Erfasser).

Ich meinte die Sache im Formdesigner die Benmik in then Thread eingebracht hat.

Grüße
TurboMagic
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
8.451 Beiträge
 
Delphi 10.4 Sydney
 
#8

AW: Ctrl-# funktioniert nicht (immer)

  Alt 7. Aug 2020, 16:23
Ich meinte die Sache im Formdesigner die Benmik in then Thread eingebracht hat.
OK. (War zwar Redeemer, aber egal)
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
38.399 Beiträge
 
Delphi 10.4 Sydney
 
#9

AW: Ctrl-# funktioniert nicht (immer)

  Alt 7. Aug 2020, 17:01
Jo das funktioniert bestimmt schon seit 10 Jahren nicht richtig und ein Muster konnte ich auch nicht erkennen.
Weiß aber auch nicht mehr wann es zuletzt war und ob es dann auch irgendwann wieder funktioniert.

Witzig ist aber, dass Strg+/ (Nummerblock) dagegen fast immer funktioniert und das Selbe macht.
Ist schon fast automatisch, dass ich dann zu / wechsel und es garnicht mehr richtig mitbekomm.
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014

Geändert von himitsu ( 7. Aug 2020 um 17:07 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
8.451 Beiträge
 
Delphi 10.4 Sydney
 
#10

AW: Ctrl-# funktioniert nicht (immer)

  Alt 7. Aug 2020, 17:13
Witzig ist aber, dass Strg+/ (Nummerblock) dagegen fast immer funktioniert und das Selbe macht.
Das ist der entsprechende Key-Code für das Englische Tastatur-Layout. Hat 'ne Weile gedauert, bis die mit unserem Code überhaupt etwas anfangen konnten. Vermutlich ist das Ganze eine rein Deutsche Angelegenheit.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +2. Es ist jetzt 20:12 Uhr.
Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf