AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Sprachen und Entwicklungsumgebungen Die Delphi-IDE Debuggen in der Delphi-IDE extrem langsam

Debuggen in der Delphi-IDE extrem langsam

Ein Thema von Sankt Rochus · begonnen am 30. Nov 2012 · letzter Beitrag vom 5. Dez 2012
Antwort Antwort
Sankt Rochus

Registriert seit: 30. Nov 2012
15 Beiträge
 
#1

Debuggen in der Delphi-IDE extrem langsam

  Alt 30. Nov 2012, 14:26
Das Debuggen von größeren Projekten ist plötzlich in meiner Delphi-10-IDE extrem langsam geworden.
Allein schon bis die Module geladen sind braucht es ca. 1 Minute, was vorher aber nur wenige Sekunden benötigt hat.
Und die Programmausführung dannach glänzt nicht gerade von Performance: Bis die Formulare aufgebaut sind, etc... .
Die Projekteinstellungen sind vermutlich nicht schuld, da das Problem auch bei anderen Projekten auftritt.
Eventuell liegt der Fehler aber in den globalen Einstellungen, vlt. habe ich dort aus Versehen einmal etwas umgestellt, was ich eigentlich gar nicht wollte.
Interessanterweise wird das Programm rasend schnell ausgeführt, wenn ich "Integriertes Debuggen" deaktiviere, dann habe ich natürlich überhaupt keine Debug-Features mehr zur Verfügung, was in meinem Fall gar nicht Okay geht.
Wenn ich eine frische Formularanwendung erstelle, funktioniert das Debuggen auch ganz normal schnell, das Problem tritt also erst bei größeren Projekten auf bzw. fällt erst dann ins Gewicht.

Unter diesen Umständen kann ich momentat kaum entwickeln. Für einen hilfreichen Tipp wäre ich sehr sehr dankbar!

Gruß
  Mit Zitat antworten Zitat
Benutzerbild von sh17
sh17

Registriert seit: 26. Okt 2005
Ort: Radebeul
1.565 Beiträge
 
Delphi 10.4 Sydney
 
#2

AW: Debuggen in der Delphi-IDE extrem langsam

  Alt 30. Nov 2012, 14:35
Wahrscheinlich nicht, aber FastMM4 nutzt Du nicht zufällig mit voller Debuggerintegration bzw Memoryleak-Kontrolle?

Oder auch ReportingMemoryLeaks vom Delphi auf true gesetzt?
Sven
--
  Mit Zitat antworten Zitat
Benutzerbild von Bernhard Geyer
Bernhard Geyer
Online

Registriert seit: 13. Aug 2002
17.032 Beiträge
 
Delphi 10.4 Sydney
 
#3

AW: Debuggen in der Delphi-IDE extrem langsam

  Alt 30. Nov 2012, 14:47
Mein Liebling: Evtl. mal Virenscanner deaktivieren? Dort kommen ja mindestens 1* Tag Updates rein die schon für die komischsten Effekt gesorgt haben.
Windows Vista - Eine neue Erfahrung in Fehlern.
  Mit Zitat antworten Zitat
Benutzerbild von himitsu
himitsu

Registriert seit: 11. Okt 2003
Ort: Elbflorenz
39.432 Beiträge
 
Delphi 11 Alexandria
 
#4

AW: Debuggen in der Delphi-IDE extrem langsam

  Alt 30. Nov 2012, 15:49
Zitat:
Oder auch ReportingMemoryLeaks vom Delphi auf true gesetzt?
Das hat nichts mir der Laufzeit zu tun.
Dieses sagt nur, daß beim Programmende, dann wenn sich der Speichermanager beenden will, noch nachgesehn wird, ob noch Speicher reserviert ist und wenn ja, daß dieses dann ausgegeben wird.
Und nur darauf hat dieses Flag einen Einfluß ... wärend der Laufzeit wird sonst nichts Zusätzliches gemacht.


PS: Ein Thread hätte doch ausgereicht?
http://www.delphipraxis.net/88953-de...ml#post1193685
(hier oder im Alten)

Nja...
Welche Delphi-Version?

Alle Updates und eventuell vorhandene (nötige) HotFixes installiert?


PS:
vor Delphi 2006 den FastMM nutzen (weiß nicht, ob man den notfalls über ShareMem auch in die alten IDEs reinbekommt)

und schau dich auch mal dort um (das sind quasi "inoffizielle" BugFixes)
http://andy.jgknet.de/blog/ide-tools/
(vorallem DelphiSpeedUp und IDE-Fix-Pack, bzw. eventuell auch die DDevExtensions)
Garbage Collector ... Delphianer erzeugen keinen Müll, also brauchen sie auch keinen Müllsucher.
Delphi-Tage 2005-2014
  Mit Zitat antworten Zitat
Sankt Rochus

Registriert seit: 30. Nov 2012
15 Beiträge
 
#5

AW: Debuggen in der Delphi-IDE extrem langsam

  Alt 5. Dez 2012, 06:56
Erstmal sorry für die zwei Threads, ich dachte, den alten Thread liest sowieso niemand mehr.
Auch sorry dafür, dass ich erst jetzt antworte, bin erst jetzt wieder am Programmieren.

Ich habe nun einen Kollegen grafragt, der mir von allen seinen globalen Delphi-Einstellungen Screenshots gegeben hat.
Dadurch bin ich durch vergleichen auf die Lösung gekommen: Für manche Komponenten war der "Debug-DCU-Pfad" nicht angegeben.
Nun, was auch immer diese Debug-DCUs sind (Ganz kurz Google gefragt: Ermöglichen das Reindebuggen in den Code von vorkompilierten Units), jedenfalls läuft die Ausführung jetzt so wie immer (nach dem Eintragen der DCU-Pfade natürlich). Was genau diese Debug-DCUs damit zu tun haben, kann ich nicht erklären.

Danke für eure Hilfe!
  Mit Zitat antworten Zitat
Benutzerbild von sh17
sh17

Registriert seit: 26. Okt 2005
Ort: Radebeul
1.565 Beiträge
 
Delphi 10.4 Sydney
 
#6

AW: Debuggen in der Delphi-IDE extrem langsam

  Alt 5. Dez 2012, 07:11
Erstmal sorry für die zwei Threads, ich dachte, den alten Thread liest sowieso niemand mehr.
Witzbold,wenn Du darauf antwortest schon...
Sven
--
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 16:43 Uhr.
Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2021 by Daniel R. Wolf