AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Delphi-PRAXiS - Lounge Klatsch und Tratsch Kleines Stabilitätsproblem mit dem PC

Kleines Stabilitätsproblem mit dem PC

Ein Thema von Popov · begonnen am 9. Jul 2013 · letzter Beitrag vom 12. Jul 2013
Antwort Antwort
Seite 1 von 4  1 23     Letzte » 
Popov
(Gast)

n/a Beiträge
 
#1

Kleines Stabilitätsproblem mit dem PC

  Alt 9. Jul 2013, 00:53
Ich hab seit einiger Zeit ein kleines Problem mit dem PC, aber auch Lösungen, wenn auch unbequeme. Vielleicht weiß jemand genauer was es ist, denn auch wenn das Problem auf den ersten Blick offensichtlich ist, ich weiß es nicht ob es tatsächlich so ist.

In der Regel kurz nach dem PC-Start, aber nicht nur, denn manchmal, wenn auch gelegentlich im Betrieb, taucht das Problem auf. Der PC friert für eine bis zwei Sekunden ein. Nichts läuft dann. Die Maus lässt sich nicht bewegen, Filme frieren ein, Musik friert ein (man hört in der Zeit ein einzigen gleichmäßigen Ton), usw.

Macht man nichts, geht es gleich weiter. Taucht das Problem auf, ist es der Anfang vom Ende. Paar Minuten später wiederholt sich das alles, wiederholt sich, wiederholt sich. Jetzt heißt es Ruhe bewahren und den PC schnell runter zu fahren. Begeht man den Fehler z. B. jetzt die Maus übermäßig zu bewegen oder auf der Tatstatur zu tippen, kann das zum Absturz führen. Also besser runter fahren.

Runterfahren alleine bringt nichts. Fährt man den PC gleich wieder hoch, wiederholt sich das Problem bald. Was ich nun mache ist den PC aufschrauben und Anschlüsse zu kontrollieren, also die SATA Anschlüsse am Board und den Geräten zu lösen, evtl. reinigen und wieder verbinden. Danach funktioniert der PC wieder normal.

Die Lösung scheint also simpel. Was mich aber etwas verwirt ist die zunehmende Häufigkeit. Nach dem ersten Mal, wo ich noch etwas länger nach der Lösung des Problems gesucht habe, habe ich paar Monate Ruhe gehabt. Ich habe aber das Gefühl, dass die Perioden immer kürzer werden. Die letzten drei Probleme tauchten im Wochenrhythmus auf.

Also, das Problem ist noch zum Teil beherrschbar - noch - es wird aber langsam lästig. Oxidierte Anschlüsse kann es nicht sein. Die reinige ich jedes Mal, so schnell können die nicht wieder oxidiert sein. Eventuell ein Haarriss/Kalte Lötstelle? Der PC verweigert den Dienst aber nicht beim Einschalten, sondern erst nach Minuten, und dann nur Sekunden. Hört sich nicht unbedingt nach Haarriss oder Kalten Lötstelle.

Vielleicht kann es jemand auch das Problem und kann genauer eingrenzen.
  Mit Zitat antworten Zitat
Benutzerbild von Dalai
Dalai

Registriert seit: 9. Apr 2006
1.263 Beiträge
 
Delphi 5 Professional
 
#2

AW: Kleines Stabilitätsproblem mit dem PC

  Alt 9. Jul 2013, 01:10
Bitte mal Informationen zur Hardware.
  • Leuchtet die HDD LED während der Rechner eingefroren ist?
  • Wie sehen die SMART-Werte der Platte aus? Hast du spaßeshalber mal das SATA-Kabel der HDD auf einen anderen Steckplatz gesteckt? Irgendwie riecht mir das nach einem sterbenden SATA-Anschluss/-Controller - ja, sowas gibt's tatsächlich und leider nicht nur bei Intel (bei denen wurde das ja bekannt).
  • Was sagt die Ereignisanzeige (Windows) oder das Syslog (Linux) dazu? Irgendwelche Fehler und/oder Warnungen?
  • Und nicht zuletzt: Wie sehen die Elkos auf dem Board aus (sofern es nicht Solid Caps sind)?

MfG Dalai
  Mit Zitat antworten Zitat
Popov
(Gast)

n/a Beiträge
 
#3

AW: Kleines Stabilitätsproblem mit dem PC

  Alt 9. Jul 2013, 02:55
Bitte mal Informationen zur Hardware.
  • Leuchtet die HDD LED während der Rechner eingefroren ist?
Eigentlich nicht. Auf sowas achte ich bewusst, es ist also nicht einfach nur eine Vermutung, sondern Beobachtung.

Nur wie gesagt, es ist ein zum Teil kontrollierbares Problem. Der PC lässt sich in der Regel herunter fahren. Ausnahme wenn man ihn zum Zeitpunkt des kurzen Ausfalls mit Input aus Tastatur und Maus ärgert. Aber auch dann leuchtet die LED nicht, ich will aber nicht ausschließen, dass es mal so gewesen ist. Es hängt einfach davon ab ob zum Zeitpunkt des Absturzes gerade auf ein Laufwerk zugegriffen wurde. Wenn, dann ist es aber eine Ausnahme. Es ist nicht die Regel, kommt auch nicht gelegentlich vor, eher Ausnahme.

Die Regel ist es übrigens, dass sich der PC da nicht komplett herunterfahren lässt. Gilt aber nur dann wenn das Problem auftaucht, sonst ja. Der PC wird herunter gefahren, die Festplatten schalten ab (man hört es), nur geht er nicht komplett aus. Man sieht noch das Bild zum Herunterfahren von Windows.

Zitat:
  • Wie sehen die SMART-Werte der Platte aus? Hast du spaßeshalber mal das SATA-Kabel der HDD auf einen anderen Steckplatz gesteckt? Irgendwie riecht mir das nach einem sterbenden SATA-Anschluss/-Controller - ja, sowas gibt's tatsächlich und leider nicht nur bei Intel (bei denen wurde das ja bekannt).
Eigentlich fast Ok. Ich hab drei festeigebaute Festplatten und in der Regel zwei Externe über USB. Da die Externen in der Regel nach einer Minute Nichtnutzung selbst aus gehen, was vermutlich zur Folge hat, dass die schon eine Million mal angelaufen sind, sind die meistens die ganze Zeit an. Von den drei Festen ist eine 120 GB sogar noch IDE. Die ist schon relativ alt (sehe gerade fast 55 Tausend Betriebsstunden). Die hat vor Jahren mal einen Knacks bekommen, ich hab sie aber drin gelassen. Trotz paar defekten Sektoren funktioniert sie seit dem eigentlich prima. Laut SMART das einzige Problem. Von dem Problem habe ich aber schon seit Jahren Kenntnis.

Die zweitälteste (auch die Systemplatte) hat "Aktuell schwebende Sektoren". Das ist ein Problem das mir jetzt erst gerade aufgefallen ist.

Die dritte Feste ist nach SMART ok.

Die Externen sind auch ok.

Zitat:
  • Was sagt die Ereignisanzeige (Windows) oder das Syslog (Linux) dazu? Irgendwelche Fehler und/oder Warnungen?
Die einzigen Fehler - sehe ich gerade - gibt es beim DVD Laufwerk. Ob die Fehler auch mit dem "Abstürzen" übereinstimmen, kann ich auf die Schnelle nicht beantworten. Auf jeden Fall hatte ich gestern anscheinen 8 Fehler zu dem Fall (aber keine 8 Abstürze). Das Laufwerk ist relativ neu, gerade mal etwa ein Jahr alt. Das Problem ist älter.

Zitat:
  • Und nicht zuletzt: Wie sehen die Elkos auf dem Board aus (sofern es nicht Solid Caps sind)?
Na ja, wild sehen die nicht gerade aus, und ich war früher Elektroniker. Aber ich guck mir das mal bei Gelegenheit genauer und mit Luppe an.
  Mit Zitat antworten Zitat
Perlsau
(Gast)

n/a Beiträge
 
#4

AW: Kleines Stabilitätsproblem mit dem PC

  Alt 9. Jul 2013, 06:02
Moin Popov,

ich hatte genau das selbe Problem auch erst kürzlich wieder, und zwar bin ich im Nachhinein darauf gekommen, daß es mit Beginn der ersten heißen Tage in disem Jahr so richtig penetrant wurde. Du ahnst es schon: Ich hatte ein Hitzeabfuhr-Problem.

Nun muß ich ein klein wenig ausholen: In meiner Kiste ist nur wenig Platz für die drei großvolumigen Sata-Platten, die ich damit betreibe. Das bedeutet, daß ich ohne zusätzliche Kühlung schnell einen Hitzestau bekomme, da der Raum zwischen den Platten jeweils nur knapp 15 mm beträgt. Da ich über eine kleinere Anzahl von Zimmer-Ventilatoren verfüge, hab ich damals kurzerhand die linke Gehäusewand der Kiste entfernt und einen Ventilator davorgestellt.

Nun funktionierte der mit der Zeit immer schlechter, was daran lag, daß sich Staub im Gitter, das den Ventilator umgibt, angesammelt hatte und so nur noch wenig Luft durchkam bzw. an der Seite statt von vorne herauskam. Damals hatte ich das Problem, da du beschreibst, schon einmal bemerkt und es durch die Reinigung des Ventilators beheben können. Natürlich denkt man da nicht ständig dran, und so kam es, wie es kommen mußte: Mit Beginn der ersten heißen Tage dieses Sommers wurde es auch in meinem Arbeitszimmer recht warm (geht nach Süden) und ich hab mich, nachdem das Problem ein paarmal auftrat, bequemt, den Ventilator wieder zu reinigen, der war tatsächlich wieder voll verstaubt (ich seh den ja nicht ständig, der steht außerhalb meiner Sichtweite). Danach war das Problem sofort weg.

Letztes Jahr hatte ich noch vier Sata-Platten mit nur jeweils ca 1 mm Abstand im Rechner, wovon zwei nach dreijährigem Gebrauch mit zu geringer Wärmeabfuhr ziemlich gleichzeitig den Geist aufgaben (zum Glück nichts Wichtiges, meine Daten-Platte wird ja täglich auf ein USB-Drive gesichert).

Wenn Festplatten so heiß werden, daß man sich schier die Finger daran verbrennt, arbeiten sie nicht mehr zuverlässig und schalten wohl auch ab. Zudem schaltet ebenfalls der Prozessor ab, wenn er überhitzt ist, und wieder ein, nachdem er ausreichend abkühlt konnte. Ich denke, daß der fehlende Zugriff auf die Systemplatte das System einfrieren läßt. Es gab da auch noch ein paar andere Phänomene, die jetzt mit ausreichender Kühlung nicht mehr auftreten:

1. Expressgate wurde beim Hochfahren manchmal nicht gefunden:
2. Systemplatten (ich hab zwei) wurden beim Hochfahren manchmal nicht gefunden, was auf fehlerhaften Bootsektor-Einträge schließen läßt.
3. Einstellungen beim Herunterfahren wurden nur unvollkommen gespeichert.
4. Der Desktop wurde beim Hochfahren nicht vollständig aufgebaut, Windows war zwar gestartet, aber nicht betriebsbereit bzw. nicht bedienbar.

Natürlich kann ich jetzt nicht mit Sicherheit sagen, daß es bei dir ebenfalls die HDs sind, aber das von dir beschriebene Verhalten deutet meiner Erfahrung nach doch sehr auf ein Hitzeproblem hin. Ich hatte beim ersten Mal, als mir dieses Phänomen begegnete, auf einen Virus, Trojaner oder sowas getippt, konnte aber beim besten Willen nichts finden. Inzwischen bin ich schlauer geworden: Wenn draußen die Sonne knallt, läuft mein Ventilator auf höchster Stufe. Einem Gewerbetreibenden half meine Lösung bereits ebenfalls, dem genügt sogar der zusätzlich eingebaute Ventilator nicht, weil der PC in einem TShirt-Druck-Laden steht, wo allein schon die Presse gewaltige Hitze verströmt. Mit dem Ventilator vor dem geöffneten Gehäuse hat er nun keine Probleme mehr (bei ihm stürzte der PC zuvor regelmäßig ab).

Alternativ wäre natürlich auch ein zweiter Ventilator im Innern des Gehäuses möglich, oder gar eine Wasserkühlung. Doch warum Geld ausgeben, wenn's auch so geht?

Geändert von Perlsau ( 9. Jul 2013 um 06:10 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von Union
Union

Registriert seit: 18. Mär 2004
Ort: Luxembourg
3.261 Beiträge
 
Delphi 7 Enterprise
 
#5

AW: Kleines Stabilitätsproblem mit dem PC

  Alt 9. Jul 2013, 07:55
Vielleicht auch ein Problem eines Treiberupdates? Lass doch mal den verifier eine Weile mitlaufen.
Ibi fas ubi proxima merces
sudo /Developer/Library/uninstall-devtools --mode=all
  Mit Zitat antworten Zitat
DelTurbo

Registriert seit: 12. Dez 2009
Ort: Troisdorf
997 Beiträge
 
Delphi 2007 Architect
 
#6

AW: Kleines Stabilitätsproblem mit dem PC

  Alt 9. Jul 2013, 09:17
  • Wie sehen die SMART-Werte der Platte aus? Hast du spaßeshalber mal das SATA-Kabel der HDD auf einen anderen Steckplatz gesteckt? Irgendwie riecht mir das nach einem sterbenden SATA-Anschluss/-Controller - ja, sowas gibt's tatsächlich und leider nicht nur bei Intel (bei denen wurde das ja bekannt).

MfG Dalai
Und eventuell mal das SATA-Kabel tauschen. Aber nur falls du beim auslesen vom SMART CRC-Fehler hast. Ich habe in meinem Server schon 3 SATA-Kabel gehabt, die nach ca. einem Jahr defekt waren. Hat mich auch gewundert das die so schnell kaputt gehen, ohne das man sie bewegt.

Gruß

PS.: Dieses "einfrieren" kann wirklich an einer platte liegen. Das hat man auch bei unix. Kann er einen Sektor nicht lesen, dann fummelt er ewig dran rum, und die load geht hoch. In diesem Moment ist nichtmal ein ls möglich.
Alle meine Rechtschreibfehler sind Urheberrechtlich geschützt!!
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
7.127 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#7

AW: Kleines Stabilitätsproblem mit dem PC

  Alt 9. Jul 2013, 10:03
Trotz paar defekten Sektoren funktioniert sie seit dem eigentlich prima. Laut SMART das einzige Problem. Von dem Problem habe ich aber schon seit Jahren Kenntnis.

Die zweitälteste (auch die Systemplatte) hat "Aktuell schwebende Sektoren". Das ist ein Problem das mir jetzt erst gerade aufgefallen ist.
Sowohl defekte Sektoren als auch schwebende Sektoren kündigen oft den Tod einer Platte an. Insbesondere schwebende Sektoren (sprich als defekt erkannte, aber noch nicht reparierte) können zu den von dir geschilderten Problemen führen. Eine vollständige Prüfung mit Checkdisk sollte die schwebenden Sektoren behandeln, sprich ersetzen oder als doch nicht defekt erkennen.

Wobei ich eine Festplatte mit schwebenden oder defekten Sektoren selbst niemals noch einsetzen würde außer zum Testen. Als Systemplatte oder für Daten, die dir irgendwie wichtig sind, sind beide jedenfalls nicht geeignet.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
DelTurbo

Registriert seit: 12. Dez 2009
Ort: Troisdorf
997 Beiträge
 
Delphi 2007 Architect
 
#8

AW: Kleines Stabilitätsproblem mit dem PC

  Alt 9. Jul 2013, 10:15
Sowohl defekte Sektoren als auch schwebende Sektoren kündigen oft den Tod einer Platte an. Insbesondere schwebende Sektoren (sprich als defekt erkannte, aber noch nicht reparierte) können zu den von dir geschilderten Problemen führen. Eine vollständige Prüfung mit Checkdisk sollte die schwebenden Sektoren behandeln, sprich ersetzen oder als doch nicht defekt erkennen.
Diese "markierten" Sektoren werden nicht beim nächsten lesen, sondern erst beim nächsten schreiben "umgelegt".
Obwohl ich ehrlich sagen muss, muss man eine 120er defekte platte wissentlich im System haben?

Gruß
Alle meine Rechtschreibfehler sind Urheberrechtlich geschützt!!
  Mit Zitat antworten Zitat
Benutzerbild von Dalai
Dalai

Registriert seit: 9. Apr 2006
1.263 Beiträge
 
Delphi 5 Professional
 
#9

AW: Kleines Stabilitätsproblem mit dem PC

  Alt 9. Jul 2013, 11:11
Die zweitälteste (auch die Systemplatte) hat "Aktuell schwebende Sektoren". Das ist ein Problem das mir jetzt erst gerade aufgefallen ist.
Dann würde ich da mal weitergrasen.

MfG Dalai
  Mit Zitat antworten Zitat
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.223 Beiträge
 
Delphi 7 Personal
 
#10

AW: Kleines Stabilitätsproblem mit dem PC

  Alt 9. Jul 2013, 11:50
Ich denke Perlsau liegt mit seiner Vermutung genau richtig.
a) Mach mal den PC sauber (wenn Du die Elkos kontrolliert hast, ist das wohl überflüssig)
b) hilf mal mit einem Ventilator (und offenem Gehäuse) der Kühlung auf die Sprünge.

Gruß
K-H
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 17:35 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf