AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Cross-Platform-Entwicklung Delphi XE6: Bekomme mein Tablet nicht eingebunden

XE6: Bekomme mein Tablet nicht eingebunden

Offene Frage von "MEissing"
Ein Thema von Kralle · begonnen am 2. Jul 2014 · letzter Beitrag vom 3. Jul 2014
Antwort Antwort
Kralle

Registriert seit: 31. Okt 2004
Ort: Bremerhaven
349 Beiträge
 
Delphi XE7 Professional
 
#1

XE6: Bekomme mein Tablet nicht eingebunden

  Alt 2. Jul 2014, 18:56
Moin,

um mein Tablet nutzen zu können, muss ich Daten in die "android_winusb.inf" eintrage. Auf meinem alten PC klappte das ohne Probleme. Wenn ich das jetzt wiederhole und die "android_winusb.inf" installieren will, kommt die Meldung:
"Der Hashwert für die Datei ist in der angegebenen Katalogdatei nicht vorhanden. Die Datei ist wahrscheinlich beschädigt oder wurde unerlaubt geändert."

Im Netz finde ich nur Tipps wie man die HASH-Überprüfung dauerhaft abschalten kann.
Kann man nicht irgendwie die ".cat"-Datei aktualisieren?

Ich hoffe, ich nicht wieder der erste/einzige mit diesem Problem.

Gruß HEiko
OS: Windows 8.1 Professional (FileSystem: NTFS),
Lazarus: 1.6 (Freepascal 3.0.0), Delphi XE7 Pro SP1 +(Mobilpack & FireDAC)
  Mit Zitat antworten Zitat
Benutzerbild von MEissing
MEissing

Registriert seit: 19. Jan 2005
Ort: Egelsbach
975 Beiträge
 
Delphi 10.3 Rio
 
#2

AW: XE6: Bekomme mein Tablet nicht eingebunden

  Alt 3. Jul 2014, 10:28
http://stackoverflow.com/questions/9...driver-and-adb

(Gibt's keinen ADB-Debug-Treiber vom Hersteller? Ich empfehle sehr gerne Google Nexus Geräte....oder zumindest einen Hersteller, der passende USB-Debug-Treiber anbietet. Genau aus diesem Grunde.)
Matthias Eißing
cu://Matthias.Eißing.de [Embarcadero]
Kein Support per PN
  Mit Zitat antworten Zitat
Kralle

Registriert seit: 31. Okt 2004
Ort: Bremerhaven
349 Beiträge
 
Delphi XE7 Professional
 
#3

AW: XE6: Bekomme mein Tablet nicht eingebunden

  Alt 3. Jul 2014, 13:05
Hallo Matthias,
Den Weg kenne ich, aber unter Windows 8.1 schlägt dann die Überprüfung der Treibersignatur zu, weil nach dem Manipulieren der Hash-Wert nicht mehr zur CAT-Datei passt.

(Gibt's keinen ADB-Debug-Treiber vom Hersteller?
Dazu konnte sich Trekstor noch nicht hinreissen lassen ...

Ich empfehle sehr gerne Google Nexus Geräte....oder zumindest einen Hersteller, der passende USB-Debug-Treiber anbietet. Genau aus diesem Grunde.)
Die kosten aber auch mehr ...

Off Topic
Aber, Embarcadero will ja seine Android-Entwickler mit XE6 scheinbar auch ärgern.
Ich habe XE6 komplett neu installiert und schaue dann in die "Optionen/SDK Manager" und was muß ich sehen?
Ein Gelber Ausrufezeichen hinter "ZipAlign-Speicherort". Auch im mitgeleiferten SDK war die "zipalign.exe" nicht zu finden. Erst nach dem Herrunterladen der aktuellen SDK-Versionen und deren Einbinden, war alles i.O.


Gruß HEiko
OS: Windows 8.1 Professional (FileSystem: NTFS),
Lazarus: 1.6 (Freepascal 3.0.0), Delphi XE7 Pro SP1 +(Mobilpack & FireDAC)
  Mit Zitat antworten Zitat
Benutzerbild von MEissing
MEissing

Registriert seit: 19. Jan 2005
Ort: Egelsbach
975 Beiträge
 
Delphi 10.3 Rio
 
#4

AW: XE6: Bekomme mein Tablet nicht eingebunden

  Alt 3. Jul 2014, 13:27
Die kosten aber auch mehr ...
Ach.... dafür funktionieren sie aber....


Aber, Embarcadero will ja seine Android-Entwickler mit XE6 scheinbar auch ärgern.
Ich habe XE6 komplett neu installiert und schaue dann in die "Optionen/SDK Manager" und was muß ich sehen?
Ein Gelber Ausrufezeichen hinter "ZipAlign-Speicherort". Auch im mitgeleiferten SDK war die "zipalign.exe" nicht zu finden. Erst nach dem Herrunterladen der aktuellen SDK-Versionen und deren Einbinden, war alles i.O.
Das ist ein Google/Android/SDK Problem, vor dem nicht nur wir stehen:
http://stackoverflow.com/questions/2...publishing-app
Matthias Eißing
cu://Matthias.Eißing.de [Embarcadero]
Kein Support per PN
  Mit Zitat antworten Zitat
Kralle

Registriert seit: 31. Okt 2004
Ort: Bremerhaven
349 Beiträge
 
Delphi XE7 Professional
 
#5

AW: XE6: Bekomme mein Tablet nicht eingebunden

  Alt 3. Jul 2014, 14:07
Hallo MAtthias,

Zitat:
Ach.... dafür funktionieren sie aber....
Mein Tablet jetzt auch.

Zitat:
Das ist ein Google/Android/SDK Problem, vor dem nicht nur wir stehen:
http://stackoverflow.com/questions/2...publishing-app
Naja, die Lösung habe ich ja hier schon gepostet

Gruß Heiko
OS: Windows 8.1 Professional (FileSystem: NTFS),
Lazarus: 1.6 (Freepascal 3.0.0), Delphi XE7 Pro SP1 +(Mobilpack & FireDAC)
  Mit Zitat antworten Zitat
Benutzerbild von MEissing
MEissing

Registriert seit: 19. Jan 2005
Ort: Egelsbach
975 Beiträge
 
Delphi 10.3 Rio
 
#6

AW: XE6: Bekomme mein Tablet nicht eingebunden

  Alt 3. Jul 2014, 14:53
Mein Tablet jetzt auch.
Dann wäre es hilfreich, wenn du beschreibst, wodran es gelegen hat.

Hallo MAtthias,
Zitat:
Das ist ein Google/Android/SDK Problem, vor dem nicht nur wir stehen:
http://stackoverflow.com/questions/2...publishing-app
Naja, die Lösung habe ich ja hier schon gepostet
Richtig.... ich wollte nur darstellen, daß das kein Embarcadero-spezifisches Problem darstellt.

Du schriebst:
Zitat:
Aber, Embarcadero will ja seine Android-Entwickler mit XE6 scheinbar auch ärgern.
Matthias Eißing
cu://Matthias.Eißing.de [Embarcadero]
Kein Support per PN
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 16:26 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf