AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Delphi spinnt

Ein Thema von Pflaumi · begonnen am 30. Mai 2019 · letzter Beitrag vom 4. Jun 2019
Antwort Antwort
Seite 2 von 3     12 3   
Benutzerbild von sakura
sakura

Registriert seit: 10. Jun 2002
Ort: München
11.486 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#11

AW: Delphi spinnt

  Alt 3. Jun 2019, 09:01
Das war der Grund, aber wie hat er es gelöst? Der externe Editor scheint ja nicht im Überscheibmodus gewesen zu sein. Also kann es eigentlich nicht an der Einfg-Taste gelegen haben, weil die wirkt sich ja global aus. Oder nur, wenn das Fenster aktiv ist? Schalte ich also vorher in den Überschreinmodus, wirkt sich das nicht auf neue Fenster/Programme aus?
Es ist davon auszugehen, dass er im externen Editor einen anderen Fehler gemacht hat und dieser dann zu dem zweiten Problem geführt hat. Ich denke, dass das eine mit dem anderen nichts zu tun hatte.

......
Daniel W.
Ich bin nicht zurück, ich tue nur so
  Mit Zitat antworten Zitat
Benutzerbild von Pflaumi
Pflaumi

Registriert seit: 21. Mai 2019
Ort: Reichenschwand
31 Beiträge
 
Delphi 7 Enterprise
 
#12

AW: Delphi spinnt

  Alt 3. Jun 2019, 15:44
Zitat:
Dieses Problem wollte ich lößen, indem ich einen anderen Editor benutzt habe (Notepad++).
Bald darauf kam von Delphi dann, dass er die Komponenten nicht versteht.
Das mit den Komponenten habe ich irgentwie gelößt (ich weiß es aber nicht mehr wie ).
Als ich dass mit der Einfg-Taste und dem Überschreibmodus gelesen habe, habe ich dass gleich ausprobiert.
Und dann hat alles wieder geklappt, deswegen nehme ich jetzt wieder den Delphi-Editor!
Felix
  Mit Zitat antworten Zitat
Delphi.Narium

Registriert seit: 27. Nov 2017
1.093 Beiträge
 
Delphi 7 Professional
 
#13

AW: Delphi spinnt

  Alt 3. Jun 2019, 21:00
Laut Profil hast Du doch Delphi 7.

Der Editor in Delphi 7 hat eine Statusbar.

Dort findest Du u. a. die Cursorposition im Editor (Zeile:Spalte).

Rechts daneben steht "Verändert", wenn der Quelltext seit dem letzten Speichern verändert wurde.

Rechts daneben steht "Einfügen" wenn der Editor im Einfügemodus ist und "Überschreiben", wenn der Überschreibmodus aktiviert ist. (Aviator wies schon darauf hin.)

Man kann dort also eigentlich immer sehen, wie der Editor bei Eingaben reagieren wird.

Achso: Die Einfügetaste funktioniert systemweit. Wenn man sie also in Delphi drückt und dann nach Notepad (mit oder ohne Plus) wechselt, bleibt das Verhalten erhalten, bis man die Taste erneut drückt. Ein Neustart der IDE dürfte von daher kaum zu einem Erfolg führen.
  Mit Zitat antworten Zitat
Benutzerbild von Luckie
Luckie
(Moderator)

Registriert seit: 29. Mai 2002
37.300 Beiträge
 
Delphi 2006 Professional
 
#14

AW: Delphi spinnt

  Alt 4. Jun 2019, 01:12
Achso: Die Einfügetaste funktioniert systemweit. Wenn man sie also in Delphi drückt und dann nach Notepad (mit oder ohne Plus) wechselt, bleibt das Verhalten erhalten, bis man die Taste erneut drückt. Ein Neustart der IDE dürfte von daher kaum zu einem Erfolg führen.
Genau so, dachte ich es mir, deswegen habe ich nach der Lösung gefragt, was er genau gemacht hat, weil eigentlich kann es nicht sein, was er beobachtet hat.
Michael
Ein Teil meines Codes würde euch verunsichern.
  Mit Zitat antworten Zitat
Benutzerbild von Ralf Kaiser
Ralf Kaiser

Registriert seit: 21. Mär 2005
Ort: Wuppertal
901 Beiträge
 
Delphi 10.1 Berlin Professional
 
#15

AW: Delphi spinnt

  Alt 4. Jun 2019, 05:41
Achso: Die Einfügetaste funktioniert systemweit. Wenn man sie also in Delphi drückt und dann nach Notepad (mit oder ohne Plus) wechselt, bleibt das Verhalten erhalten, bis man die Taste erneut drückt. Ein Neustart der IDE dürfte von daher kaum zu einem Erfolg führen.
Bei mir (Deplhi Tokyo) kümmert sich Delphi nicht um das globale einschalten des Einfüge-Modus. Ich hab mal 3 verschiedene Editoren gestartet (einer davon Delphi), alle zeigen den Einfügemodus in ihrer Statusbar an, dann die "Einfügen"-Taste gedrückt. Die anderen Editoren zeigten sofort den Wechsel an, Delphi nicht (Delphi hatte zu der Zeit nicht den Fokus).

Kann das jemand bestätigen? Oder ist an meiner Delphi-Installation was kaputt?
Ralf Kaiser
  Mit Zitat antworten Zitat
Benutzerbild von blawen
blawen

Registriert seit: 30. Nov 2003
Ort: Luterbach (CH)
393 Beiträge
 
Delphi 10.3 Rio
 
#16

AW: Delphi spinnt

  Alt 4. Jun 2019, 05:59
Achso: Die Einfügetaste funktioniert systemweit. Wenn man sie also in Delphi drückt und dann nach Notepad (mit oder ohne Plus) wechselt, bleibt das Verhalten erhalten, bis man die Taste erneut drückt. Ein Neustart der IDE dürfte von daher kaum zu einem Erfolg führen.
Bei mir (Deplhi Tokyo) kümmert sich Delphi nicht um das globale einschalten des Einfüge-Modus. Ich hab mal 3 verschiedene Editoren gestartet (einer davon Delphi), alle zeigen den Einfügemodus in ihrer Statusbar an, dann die "Einfügen"-Taste gedrückt. Die anderen Editoren zeigten sofort den Wechsel an, Delphi nicht (Delphi hatte zu der Zeit nicht den Fokus).

Kann das jemand bestätigen? Oder ist an meiner Delphi-Installation was kaputt?
Getestet habe ich mit 10.3.1 und Notepad+. Wenn ich jeweils im Editor den Einfügemodus geändert habe, hat die andere Anwendung nichts mitbekommen.
Roland
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
7.268 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#17

AW: Delphi spinnt

  Alt 4. Jun 2019, 06:11
Achso: Die Einfügetaste funktioniert systemweit. Wenn man sie also in Delphi drückt und dann nach Notepad (mit oder ohne Plus) wechselt, bleibt das Verhalten erhalten, bis man die Taste erneut drückt.
Das ist bei mir nicht so, egal welches Tool ich benutze. (Windows 10)

Bei Delphi habe ich aber selten einen komischen Modus gehabt, bei dem der Editor, wenn ich etwas markiert habe das nicht mehr überschrieben hat, sondern markiert vor dem Cursor hergeschoben hat usw., was sich nur durch einen Neustart von Delphi lösen ließ.
In aktuellen Versionen kann ich mich daran aber nicht erinnern.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!

Geändert von jaenicke ( 4. Jun 2019 um 06:13 Uhr)
  Mit Zitat antworten Zitat
peterbelow

Registriert seit: 12. Jan 2019
Ort: Hessen
358 Beiträge
 
Delphi 10.3 Rio
 
#18

AW: Delphi spinnt

  Alt 4. Jun 2019, 12:52
Achso: Die Einfügetaste funktioniert systemweit. Wenn man sie also in Delphi drückt und dann nach Notepad (mit oder ohne Plus) wechselt, bleibt das Verhalten erhalten, bis man die Taste erneut drückt.
Das ist bei mir nicht so, egal welches Tool ich benutze. (Windows 10)

Bei Delphi habe ich aber selten einen komischen Modus gehabt, bei dem der Editor, wenn ich etwas markiert habe das nicht mehr überschrieben hat, sondern markiert vor dem Cursor hergeschoben hat usw., was sich nur durch einen Neustart von Delphi lösen ließ.
In aktuellen Versionen kann ich mich daran aber nicht erinnern.
Das ist der "persistent blocks" Modus. Es scheint irgend einen obskuren Tastaturshortcut zu geben, der den aktiviert und den man mitunter versehendlich erwischt. Das kann man aber in den Editor-Optionen im Tools-> Options dialog wieder zurücksetzen, auch ohne die IDE neu zu starten. Manchmal muss man die Option aber im Dialog erst anschalten, Dialog schließen, nochmal aufmachen und die Options wieder abschalten. Der gespeicherte Status scheint da manchmal nicht mehr synchron mit der Realität zu sein.
Peter Below
  Mit Zitat antworten Zitat
Benutzerbild von Codehunter
Codehunter

Registriert seit: 3. Jun 2003
Ort: Thüringen
1.949 Beiträge
 
Delphi 10.2 Tokyo Professional
 
#19

AW: Delphi spinnt

  Alt 4. Jun 2019, 13:58
Das ist der "persistent blocks" Modus. Es scheint irgend einen obskuren Tastaturshortcut zu geben, der den aktiviert und den man mitunter versehendlich erwischt. Das kann man aber in den Editor-Optionen im Tools-> Options dialog wieder zurücksetzen, auch ohne die IDE neu zu starten.
Die Diskussion hatten wir letztens schon mal hier. Ich bin mittlerweile der Ansicht, dass eines meiner IDE-Plugins (CnPack, GExperts, MMX) da seine Finger im Spiel hat. Einen "obskuren Shortcut" kann ich inzwischen ziemlich sicher ausschließen. Eher ein obskures Remapping von ganz und gar nicht obskuren Standard-Shortcuts. Um den Persistent-Blocks-Mode wieder abzuschalten, genügt es, 2x Einfg zu drücken. Einfacher geht es über die Optionen auch nicht.
Ich mache grundsätzlich keine Screenshots. Schießen auf Bildschirme gibt nämlich hässliche Pixelfehler und schadet der Gesundheit vom Kollegen gegenüber. I und E zu vertauschen hätte den selben negativen Effekt, würde aber eher dem Betriebsklima schaden
  Mit Zitat antworten Zitat
Benutzerbild von Pflaumi
Pflaumi

Registriert seit: 21. Mai 2019
Ort: Reichenschwand
31 Beiträge
 
Delphi 7 Enterprise
 
#20

AW: Delphi spinnt

  Alt 4. Jun 2019, 14:31
In der Statusbar des Quelltext-Editors habe ich dass mit dem Einfügen und Überschreiben gefunden.
Blos dass hatte ich davor noch nicht gewusst.
Dass Ganze ist mir gestern nochmal passiert, doch zum Glück wusste ich gleich, was los war!
Felix
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 10:08 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf