AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Rio 10.3.1 - Setup die xte

Ein Thema von TigerLilly · begonnen am 18. Feb 2019 · letzter Beitrag vom 23. Feb 2019
Antwort Antwort
Seite 2 von 3     12 3   
Der schöne Günther
Online

Registriert seit: 6. Mär 2013
5.066 Beiträge
 
Delphi 10 Seattle Enterprise
 
#11

AW: Rio 10.3.1 - Setup die xte

  Alt 19. Feb 2019, 12:35
Da ist das RAD Studio leider nicht alleine. Sehr, sehr viele Setups starten ihr Programm nach Abschluss gerne (auch ungefragt) selbst, dann natürlich mit Admin-Rechten.
  Mit Zitat antworten Zitat
MichaelT

Registriert seit: 14. Sep 2005
Ort: 4020 Linz
508 Beiträge
 
Delphi 10.3 Rio
 
#12

AW: Rio 10.3.1 - Setup die xte

  Alt 19. Feb 2019, 17:20
Die Neuerungen sind tatsächlich sehr gut. Insbesondere das setzen der Desktops ist ein Segen. Das Outlining der Codeblöcke funktioniert ganz gut mittlerweile usw...

Bei mir beginnt der Installer beim Ändern und Nachinstallieren der Mobilen Plattformen aufs Web zuzugreifen und kann nicht mehr weiter oder ich mache eine Neuinstallation und ich habe zwar alles drauf inkl. Android SDKs, aber App erstellen kann man nicht.

Ich muss mir das mal in Ruhe zu Gemüte führen. Hänge möglw. mit dem Tokyo + Mobile Key zusammen. Wird sich schon weisen.

Das trübt tatsächlich ein wenig die Freude.

---

Alle komplexeren Installer haben Troubles. Kann die mit dem VS genauso passieren.


Letzter Punkt: Ich steh auf Delphi + find die Neuerungen mit Rio toll. Aber es kann doch nicht sein, dass man alle 6 Monate sich so ein Desaster antun muss.
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke
Online

Registriert seit: 10. Jun 2003
Ort: Berlin
7.345 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#13

AW: Rio 10.3.1 - Setup die xte

  Alt 19. Feb 2019, 18:04
Zitat:
Es war gar nicht so gedacht, dass der alte ISO-Installer noch lange existiert. Ich hoffe auch, dass dieser wie angekündigt nun bald verschwindet. Das wurde bisher wohl nur nicht gemacht, weil manche mit dem Webinstaller noch Probleme haben.
Mitnichten, eine Möglichkeit zur offline-Installation ist unbedingt notwendig.
Meines Wissens soll der ISO-Installer schon bleiben, allerdings auf Basis des Web-Installers
Die Betonung lag auf "der alte ISO-Installer". Das war damit gemeint.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
Benutzerbild von Uwe Raabe
Uwe Raabe

Registriert seit: 20. Jan 2006
Ort: Lübbecke
7.180 Beiträge
 
Delphi 10.3 Rio
 
#14

AW: Rio 10.3.1 - Setup die xte

  Alt 19. Feb 2019, 18:45
Die Betonung lag auf "der alte ISO-Installer". Das war damit gemeint.
Wollte ich nur nochmal hervorheben.
Uwe Raabe
Certified Delphi Master Developer
Embarcadero MVP
Blog: The Art of Delphi Programming
  Mit Zitat antworten Zitat
Michael II

Registriert seit: 1. Dez 2012
Ort: Region Bern CH
331 Beiträge
 
Delphi 10.3 Rio
 
#15

AW: Rio 10.3.1 - Setup die xte

  Alt 20. Feb 2019, 13:34
Zitat:
Bei mir beginnt der Installer beim Ändern und Nachinstallieren der Mobilen Plattformen aufs Web zuzugreifen und kann nicht mehr weiter oder ich mache eine Neuinstallation und ich habe zwar alles drauf inkl. Android SDKs, aber App erstellen kann man nicht.
Beim ersten herausgegebenen Setup von 10.3 gab's dieses Problem bei "Pro+Mobile". Damals half es, die Lizenz zu löschen und neu einzugeben:

Zitat:
Im Lizenzmanager die aktive Lizenz löschen,
dann eine neue Lizenz mit der aktiven Lizenznummer hinzufügen
und dann noch alles registrieren.
Ich habe "Pro+Mobile", jetzt 10.3.1 drauf und kann (ohne dass ich die Lizenz löschen und neu eingeben musste) Apps erstellen.


Falls iso Installation:
Wenn nach der Installation Teile fehlen (und vorher bereits eine Version installiert war) und falls die iso immer noch mit InstallAware erstellt wird, dann hilft bei Installaware Setups oft dies:

Programm deinstallieren

Im Ordner
:\ProgramData\ nach allen versteckten Verzeichnissen suchen, welche die Setup Datei enthalten und all diese Verzeichnisse löschen.

Programm neu installieren
Michael Gasser
  Mit Zitat antworten Zitat
MichaelT

Registriert seit: 14. Sep 2005
Ort: 4020 Linz
508 Beiträge
 
Delphi 10.3 Rio
 
#16

AW: Rio 10.3.1 - Setup die xte

  Alt 20. Feb 2019, 14:36
Danke für das Feedback. Den Thread habe ich beachtet.

Ich habe das alles heute Vormittag probiert und jetzt aufgegeben.

Ich habe den Schlüssel Delphi Tokyo Pro + Mobile Add-On Pack mit dem Lizenzmanager von Tokyo gelöscht, sonst verschwindet er nicht.

Mich beschleicht der Verdacht, dass ich keine aktive Lizenznummer habe resp. weiß ich nicht was das heißt. Ich habe eine für Pro, für C/S Add-On und eine für das Mobile-Pack (Geschenk von EMB für letztes Jahr). Die Email zum Erscheinen von 10.3 habe ich bekommen.

Der Schlüssel (Tokyo Pro und Mobile Pack) wird nicht upgedatet, selbst wenn ich ihn neu erfasse. Die Schlüsseln für Delphi Pro C/S sehr wohl.

Seitdem ich den Schlüssel einmal im Setup Programm unter dem Punkt Upgrade hatte eingegeben kann ich die Plattformen zur Installation auswählen. In dem Zusammenhang kam bis zur vollen Deinstallation eine Seite im Installer mit dem Hinweis auf ein schreibbare Download Location. Das Verhalten ist mit der vollen Deinstallation von Rio verschwunden.

Heute konnte vom Web etwas runtergeladen werden und auch der Hinweis im Installer auf eine schreibbare Download Location kam nicht mehr. Installiert wird alles. Die Platformen können nicht ausgewählt werden, wenn man ein App erstellt. Es wird auch keine BPL zu dem Thema Mobile geladen. Platform SDKs sind da usw...

Sei es drum, es ist egal. Mich hat allein gewundert, dass etwas was sowieso dabei nicht installierbar wäre.

--

Es ist tatsächlich ein wenig schade, da Rio Update 1 sehr gut und performant läuft.

Aber macht wenig Sinn das Thema warum Mobile Pack nicht installiert weiter zu verfolgen. Wir schon irgendwann mal werden.



Zitat:
Bei mir beginnt der Installer beim Ändern und Nachinstallieren der Mobilen Plattformen aufs Web zuzugreifen und kann nicht mehr weiter oder ich mache eine Neuinstallation und ich habe zwar alles drauf inkl. Android SDKs, aber App erstellen kann man nicht.
Beim ersten herausgegebenen Setup von 10.3 gab's dieses Problem bei "Pro+Mobile". Damals half es, die Lizenz zu löschen und neu einzugeben:

Zitat:
Im Lizenzmanager die aktive Lizenz löschen,
dann eine neue Lizenz mit der aktiven Lizenznummer hinzufügen
und dann noch alles registrieren.
Ich habe "Pro+Mobile", jetzt 10.3.1 drauf und kann (ohne dass ich die Lizenz löschen und neu eingeben musste) Apps erstellen.


Falls iso Installation:
Wenn nach der Installation Teile fehlen (und vorher bereits eine Version installiert war) und falls die iso immer noch mit InstallAware erstellt wird, dann hilft bei Installaware Setups oft dies:

Programm deinstallieren

Im Ordner
:\ProgramData\ nach allen versteckten Verzeichnissen suchen, welche die Setup Datei enthalten und all diese Verzeichnisse löschen.

Programm neu installieren
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke
Online

Registriert seit: 10. Jun 2003
Ort: Berlin
7.345 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#17

AW: Rio 10.3.1 - Setup die xte

  Alt 20. Feb 2019, 21:04
Aber macht wenig Sinn das Thema warum Mobile Pack nicht installiert weiter zu verfolgen. Wir schon irgendwann mal werden.
Die mobile Entwicklung ist nun in der Professional und sogar der kostenlosen Community Edition enthalten, daher gibt es kein separates Mobile Addon mehr.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
MichaelT

Registriert seit: 14. Sep 2005
Ort: 4020 Linz
508 Beiträge
 
Delphi 10.3 Rio
 
#18

AW: Rio 10.3.1 - Setup die xte

  Alt 20. Feb 2019, 23:44
Danke. Soweit bin ich schon.

Es stellt sich allein die Frage warum dann der Installer diesen Teil zuerst nicht anbietet und später nach vermeintlich gelungener Installation nicht aktiviert, wenn das Mobile Add-On Pack sowieso integriert ist. Ich gebe recht, es nimmt einen selbst für einen kurzen Moment ein wenig Wunder.

Der SA läuft noch. Wenn das Verhalten mehrere betrifft, dann wird die EMB sich etwas einfallen lassen müssen. Peinlich ist das schon.

---

Mich persönlich kratzt das Thema jetzt im Moment nicht wirklich. Das war gemeint. Das Thema Multiplatform rückt bei mir bis 10.4 und der 64-bit OS/X Unterstützung (und wie das ganze konkret im Zusammenspiel mit der GUI funktioniert) nicht eilig in den Vordergrund.

Wenn es ginge wäre es schöner, dann könnte ich Tokyo stanzen.

Ich freute mich über das Mobile Add-On Pack zu Tokyo. Geschenkter Gaul Maul ... In Summe über alles ist die Multiplatform Lösung ganz gut gemacht und soviel ich gesehen habe wurde die PAServer Anbindung und der Editor in Rio schneller.

Bis zur Version vermutlich 10.3.3 setze ich mal die rosarote Brille auf und freue mich über die Verbesserungen.

---

Unter vertrauensbildende Maßnahme fällt die Installation diesmal nicht. Wobei die Installation selbst eher flink vonstatten geht. Es gibt viel Positives zu vermelden auch.

Vermutlich handelt sich um ein anderes technisches Gebrechen, das mit dem ISO Installer in Zusammenhang steht oder es hat etwas mit dem Account. Selbst dem Uwe sein 'Projektmanger' findet bei manchen Usern die Plattformen, allein die EMB nicht.

---

Ich werde sowieso am Ende um eine Enterprise Version auf einem neuen Rechner im Herbst nicht umhinkommen. Aber bevor ich mir tatsächlich RAD-Studio Enterprise gebe muss der Teil halbwegs schnurren, was das Jahr beim Herbst ... von Jahr zu Jahr schiebt.

---

Ich verlasse mich aber nicht auf einen Web Installer.


Aber macht wenig Sinn das Thema warum Mobile Pack nicht installiert weiter zu verfolgen. Wir schon irgendwann mal werden.
Die mobile Entwicklung ist nun in der Professional und sogar der kostenlosen Community Edition enthalten, daher gibt es kein separates Mobile Addon mehr.
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke
Online

Registriert seit: 10. Jun 2003
Ort: Berlin
7.345 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#19

AW: Rio 10.3.1 - Setup die xte

  Alt 21. Feb 2019, 08:55
Ich verlasse mich aber nicht auf einen Web Installer.
Der ISO Installer ist wirklich nur noch eine Notlösung, wenn der Webinstaller nicht funktioniert!
Dass da manche Konstellationen nicht mehr abgebildet werden, ist durchaus möglich.

Beim Webinstaller kannst du auch noch nach der Installation die Plattformen einfach in der IDE per Menübefehl hinzufügen oder entfernen.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
MichaelT

Registriert seit: 14. Sep 2005
Ort: 4020 Linz
508 Beiträge
 
Delphi 10.3 Rio
 
#20

AW: Rio 10.3.1 - Setup die xte

  Alt 21. Feb 2019, 09:42
Schauen wir mal. Support Case ist aufgemacht.

Zumal die Files installiert werden konnten ... Märchenstunde ist am Nachmittag für Kinder.

Auf Dauer wird der Umfang für eine ISO Image zu groß. Da ist was dran. Wenn ich mir selbst eine Zusammenladen muss wie beim MS Produkten habe Kundenarbeit ...

Ich verlasse mich aber nicht auf einen Web Installer.
Der ISO Installer ist wirklich nur noch eine Notlösung, wenn der Webinstaller nicht funktioniert!
Dass da manche Konstellationen nicht mehr abgebildet werden, ist durchaus möglich.

Beim Webinstaller kannst du auch noch nach der Installation die Plattformen einfach in der IDE per Menübefehl hinzufügen oder entfernen.
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 17:35 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf