AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren

Rio 10.3.1 - Setup die xte

Ein Thema von TigerLilly · begonnen am 18. Feb 2019 · letzter Beitrag vom 22. Feb 2019
Antwort Antwort
Seite 3 von 3     123
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
7.287 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#21

AW: Rio 10.3.1 - Setup die xte

  Alt 21. Feb 2019, 09:36
Auf Dauer wird der Umfang für eine ISO Image zu groß.
Es wird ja auch wieder eine neue ISO geben, nur auf Basis des neuen Installers, der jetzt als Webinstaller verwendet wird. Die Größe ist da weniger das Problem.

Der neue Installer ist einfach modularer, flexibler und schneller, so dass der alte Installer wirklich nur benutzt werden sollte, wenn es nicht anders geht.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
MichaelT

Registriert seit: 14. Sep 2005
Ort: 4020 Linz
496 Beiträge
 
Delphi 10.3 Rio
 
#22

AW: Rio 10.3.1 - Setup die xte

  Alt 21. Feb 2019, 10:45
Soweit so gut.

Der Webinstaller ist überhaupt ein anderer/neuer. Ok. Danke. Das habe ich wieder vergessen.

Um welchen Installer es sich handelt solange er funktioniert ist mir egal. Gut ist wenn man einen konsistenten Stand von Zeit zu Zeit hat. Es wird der Tag an dem die Meute aktuelle Änderungen ziehen will . Aber schauen wir mal.

---

Eine Full Installation bei immer mehr Plattformen wird mit der Zeit sowieso nicht mehr gangbar.

Im Umfeld C/C++ Umfeld sammeln sich Unmengen an Files. Bei Delphi allein betrachtet ist der Aspekt noch nicht so dramatisch.

---

Mit Rio hat sich soviel ich bisher sah einiges grad auch im Umfeld Editor stark verbessert und die Behandlung der Desktops. Bspw. ist Code/Design/History viel intuitiver platziert und lädt dazu ein sich die History anzusehen.


Die Möglichkeit Variablen sehr gezielt einführen kann macht Sinn und war schon ein Zeiterl überfällig. Die IDE reagiert schnell.

---

Die Gesamtleistung inkl. ARM Support ist auf keinen Fall zu verachten. Über die Jahre ist Leistung von EMB nicht zu verachten.


Auf Dauer wird der Umfang für eine ISO Image zu groß.
Es wird ja auch wieder eine neue ISO geben, nur auf Basis des neuen Installers, der jetzt als Webinstaller verwendet wird. Die Größe ist da weniger das Problem.

Der neue Installer ist einfach modularer, flexibler und schneller, so dass der alte Installer wirklich nur benutzt werden sollte, wenn es nicht anders geht.
  Mit Zitat antworten Zitat
Benutzerbild von jaenicke
jaenicke

Registriert seit: 10. Jun 2003
Ort: Berlin
7.287 Beiträge
 
Delphi 10.2 Tokyo Enterprise
 
#23

AW: Rio 10.3.1 - Setup die xte

  Alt 21. Feb 2019, 12:30
Eine Full Installation bei immer mehr Plattformen wird mit der Zeit sowieso nicht mehr gangbar.
Genau darum geht es. Der alte Installer konnte zwar auch nachträglich die Plattformen ändern, aber es war ziemlich aufwendig. Mit dem neuen ist das der Standardweg und sehr einfach.
Sebastian Jänicke
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
  Mit Zitat antworten Zitat
MichaelT

Registriert seit: 14. Sep 2005
Ort: 4020 Linz
496 Beiträge
 
Delphi 10.3 Rio
 
#24

AW: Rio 10.3.1 - Setup die xte

  Alt 21. Feb 2019, 13:11
Danke.

Soweit hatte ich mich bisher nicht beschäftigt mit dem Thema, da ich sowieso 'nur' Prof C/S hatte und das Umfeld funktioniert an sich ein Weilchen und im Moment sehr gut.

Ich deckte eine Zeit lang eher Eigenbedarf. In dem Fall wird Konzeptpapier sehr geduldig.

Meine Referenzprojekte sind im wahrsten Sinne des Wortes schon ein wenig ClBtnFace angegraut.

Langsam muss ich wieder mal ein wenig peppigere Sachen machen. Sonst glaubt keiner mehr inklusive mir selbst, dass ich noch Informatiker bin. . Vor ein paar Jahren hat das Styling Thema keinen wirklich interessiert und langsam rückt das in meinem eher durchwegs konservativen Umfeld in den Fokus.

Durch diese laufenden Diskussionen rund um die großen Schuppen hat sich der Trend das ungeliebte Kind IT außer Haus zu transferieren eher abgeschwächt, obwohl langsam kommen 'wir' drauf, dass VPN allein nicht 'Digitalisierung' genug ist.

Läuft alles noch unter dem Deckmantel Beratung, aber etwas moderne frische Lösungsansätze herzuzeigen beruhigt zumindest die Gemüter . So frei nach dem Motto EMS und Style Controls sorg(t)en für Seelenfrieden.

Eine Full Installation bei immer mehr Plattformen wird mit der Zeit sowieso nicht mehr gangbar.
Genau darum geht es. Der alte Installer konnte zwar auch nachträglich die Plattformen ändern, aber es war ziemlich aufwendig. Mit dem neuen ist das der Standardweg und sehr einfach.
  Mit Zitat antworten Zitat
MichaelT

Registriert seit: 14. Sep 2005
Ort: 4020 Linz
496 Beiträge
 
Delphi 10.3 Rio
 
#25

AW: Rio 10.3.1 - Setup die xte

  Alt 22. Feb 2019, 11:54
Der Webinstaller selbst ist übersichtlich und ganz gut gemacht. Man sieht wunderbar wie alles installiert wird, schön der Reihe nach.

Auf jeden Fall kann ich beruhigt sagen, egal ob ISO oder Webinstaller die mobilen Sachen werden installiert und stehen beim Erstellen der Apps nicht zur Verfügung.

Jo mei. Warten wir auf den RIO Nachfolger.


Auf Dauer wird der Umfang für eine ISO Image zu groß.
Es wird ja auch wieder eine neue ISO geben, nur auf Basis des neuen Installers, der jetzt als Webinstaller verwendet wird. Die Größe ist da weniger das Problem.

Der neue Installer ist einfach modularer, flexibler und schneller, so dass der alte Installer wirklich nur benutzt werden sollte, wenn es nicht anders geht.
  Mit Zitat antworten Zitat
Rollo62

Registriert seit: 15. Mär 2007
2.135 Beiträge
 
Delphi 10.3 Rio
 
#26

AW: Rio 10.3.1 - Setup die xte

  Alt 22. Feb 2019, 17:21
Zitat:
Der Webinstaller selbst ist etwas zu übersichtlich ...
für meinen Geschmack.

Wir sind doch keine Technik-Noobs

Gegen ein paar sauber dargestellte Optionen habe ich gar nichts.
Schlimmer finde ich das man z.B. kaum das Einstellen des Installationspfades findet.
  Mit Zitat antworten Zitat
arnold mueller

Registriert seit: 27. Jul 2005
89 Beiträge
 
#27

AW: Rio 10.3.1 - Setup die xte

  Alt 22. Feb 2019, 18:15
Der Webinstaller selbst ist übersichtlich und ganz gut gemacht. Man sieht wunderbar wie alles installiert wird, schön der Reihe nach.

Auf jeden Fall kann ich beruhigt sagen, egal ob ISO oder Webinstaller die mobilen Sachen werden installiert und stehen beim Erstellen der Apps nicht zur Verfügung.

Jo mei. Warten wir auf den RIO Nachfolger.

Bei mir hat folgendes geholfen:

Ausgangspunkt 10.2.3; Delphi Pro, Mobile-Pack und FireDac C/S.

10.2.x deinstallieren und alle Slip-Files im AllUser Verzeichnis löschen.

Danach mit dem ISO-Image 10.3.1 installieren und die Delphi-Pro und FireDac C/S Lizenz neu eingeben. Installation durchlaufen lassen und das Embarcadero Verzeichnis sichern. Die FireDAC C/S Lizenz führt dazu, dass man keine Mobile-Apps erstellen kann, daher 10.3.1 wieder deinstallieren. Die Slip-Datei für FireDac C/S löschen (mit der 19 im Namen) und die Installation nochmal durchführen. Es müssen jetzt keine Lizenzdaten neu eingegeben werden, der Installer erkennt die Delphi Pro Lizenz. Wenn die Installation durchgelaufen ist hat man ein Delphi Pro mit Mobile. Jetzt die beiden Embarcadero Verzeichnis - die Sicherung von eben und das Aktuelle mit z.B. BeyondCompare vergleichen und die fehlenden Dateien (insbesondere die FireDac-Sachen) aus der Sicherung in das aktuelle Verzeichnis kopieren. Danach hat mal Delphi Pro mit Mobile und FireDac C/S.


Der Support kennt die Problematik kann aber keine sinnvolle Lösung anbieten.
  Mit Zitat antworten Zitat
MichaelT

Registriert seit: 14. Sep 2005
Ort: 4020 Linz
496 Beiträge
 
Delphi 10.3 Rio
 
#28

AW: Rio 10.3.1 - Setup die xte

  Alt 22. Feb 2019, 22:57
Danke

Ich bin tief beeindruckt. Diese Rezeptur ist erstaunlich.

--

Dacht ich's mir, dass es mit etwas mit dem C/S auf sich hat.

--

Aber ehrlich. Ich bleibe bei dem was ich jetzt habe. Ich bin eher froh, dass mein Rechner nachdem ich die temporären Directories ausgeräumt habe neben anderen Aktionen wieder schneller bootet.

Muss ich jetzt mal testen.

Auf jeden Fall. Besten Dank.

Der Webinstaller selbst ist übersichtlich und ganz gut gemacht. Man sieht wunderbar wie alles installiert wird, schön der Reihe nach.

Auf jeden Fall kann ich beruhigt sagen, egal ob ISO oder Webinstaller die mobilen Sachen werden installiert und stehen beim Erstellen der Apps nicht zur Verfügung.

Jo mei. Warten wir auf den RIO Nachfolger.

Bei mir hat folgendes geholfen:

Ausgangspunkt 10.2.3; Delphi Pro, Mobile-Pack und FireDac C/S.

10.2.x deinstallieren und alle Slip-Files im AllUser Verzeichnis löschen.

Danach mit dem ISO-Image 10.3.1 installieren und die Delphi-Pro und FireDac C/S Lizenz neu eingeben. Installation durchlaufen lassen und das Embarcadero Verzeichnis sichern. Die FireDAC C/S Lizenz führt dazu, dass man keine Mobile-Apps erstellen kann, daher 10.3.1 wieder deinstallieren. Die Slip-Datei für FireDac C/S löschen (mit der 19 im Namen) und die Installation nochmal durchführen. Es müssen jetzt keine Lizenzdaten neu eingegeben werden, der Installer erkennt die Delphi Pro Lizenz. Wenn die Installation durchgelaufen ist hat man ein Delphi Pro mit Mobile. Jetzt die beiden Embarcadero Verzeichnis - die Sicherung von eben und das Aktuelle mit z.B. BeyondCompare vergleichen und die fehlenden Dateien (insbesondere die FireDac-Sachen) aus der Sicherung in das aktuelle Verzeichnis kopieren. Danach hat mal Delphi Pro mit Mobile und FireDac C/S.


Der Support kennt die Problematik kann aber keine sinnvolle Lösung anbieten.
  Mit Zitat antworten Zitat
MichaelT

Registriert seit: 14. Sep 2005
Ort: 4020 Linz
496 Beiträge
 
Delphi 10.3 Rio
 
#29

AW: Rio 10.3.1 - Setup die xte

  Alt 22. Feb 2019, 23:06
So zurück.

Mich beschleicht ein Verdacht, aber der Fairness halber muss ich das genauer analysieren. Ich will der EMB nicht für alles und jedes eine wie auch immer geartete Schuld in die Schuhe schieben. Wobei das einzige Programm das ich heute ausführte der Webinstaller vom RAD Studio war.

Das TMP Verzeichnis zu verlegen schadet offensichtlich nicht.

Damit bin ich mal fertig mit meinem Erfahrungsbericht.

--

Edit: Es war diesmal nicht die EMB sondern der Brave Browser und ein paar andere Kandidaten die AppData Verzeichnisse 'versaut' haben.

An sich funktioniert RIO ganz gut. Das muss man der EMB lassen.


Muss ich jetzt mal testen.

Geändert von MichaelT (23. Feb 2019 um 10:16 Uhr)
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 02:09 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf