AGB  ·  Datenschutz  ·  Impressum  







Anmelden
Nützliche Links
Registrieren
Zurück Delphi-PRAXiS Programmierung allgemein Datenbanken Query springt nicht zum ersten Datensatz

Query springt nicht zum ersten Datensatz

Ein Thema von Ykcim · begonnen am 1. Mär 2019 · letzter Beitrag vom 1. Mär 2019
Antwort Antwort
Seite 2 von 3     12 3   
Lemmy

Registriert seit: 8. Jun 2002
Ort: Berglen
2.160 Beiträge
 
Delphi 7 Professional
 
#11

AW: Query springt nicht zum ersten Datensatz

  Alt 1. Mär 2019, 10:39
Und wenn schon dynamisch per Query, warum machst du nicht gleich eine Query, die genau den gesuchten Wert holt, statt dieses "Gehampel" (
warum einfach, wenn es auch kompliziert geht?
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.165 Beiträge
 
Delphi 10.1 Berlin Professional
 
#12

AW: Query springt nicht zum ersten Datensatz

  Alt 1. Mär 2019, 10:40
Zitat:
keine Lösung, dafür Fragen..
Ich kürze das mal ab...
Delphi-Quellcode:
function TMySQLDB.Find_Property(Einstellung, Spalte: string): string;
var I: integer;
begin
   Result := '';
   FQuery_Einstellungen.First;
   while not FQuery_Einstellungen.Eof do
   begin
      if FQuery_Einstellungen.FieldByName('Einstellung').AsString = Einstellung then
      begin
        Result := FQuery_Einstellungen.FieldByName(Spalte).AsString;
        Break;
      end;
     FQuery_Einstellungen.Next;
   end;
end;
  Mit Zitat antworten Zitat
Jumpy

Registriert seit: 9. Dez 2010
Ort: Mönchengladbach
1.552 Beiträge
 
Delphi 6 Enterprise
 
#13

AW: Query springt nicht zum ersten Datensatz

  Alt 1. Mär 2019, 10:42
Zitat:
Ich kenne Unidac nicht, aber gibt es da kein Locate o.ä.?
...das hilft aber nicht bei offensichtlichen Logikfehlern.
Das stimmt schon, aber dann wäre das ganze Schleifen-Geraffel nicht nötig und dann wäre auch der Fehler weg.
Wenn man es aber schon mit Schleife macht, wäre es vllt. sinngemäß so einfacher:

Delphi-Quellcode:
Result:='Default oder Dummy oder nix';
Query.First
while not Query.EOF do
  begin
  if Query.FieldByName('Eingabe').AsString='Eingabethen
    begin
    Result:=Query.FieldByName('Angabe').AsString;
    break;
    end;
  Query.Next
  end;
Nützt aber natürlich nix, wenn Query.First wirklich nicht funzt wegen unidirectionalem Cursor o.ä.

Evtl. kann man die Query nur lokal in der Funktion benutzen und jedes mal neu aufmachen, dann steht sie autom. immer auf dem ersten Datensatz.
Ralph
  Mit Zitat antworten Zitat
Ykcim

Registriert seit: 29. Dez 2006
Ort: NRW
639 Beiträge
 
Delphi XE5 Professional
 
#14

AW: Query springt nicht zum ersten Datensatz

  Alt 1. Mär 2019, 10:43
Zitat:
wie sieht der Wert von FQuery_Einstellungen.FieldByName('Einstellung').As String vor und nach FQuery_Einstellungen.First; aus? das schon geprüft? Oder wie stellst Du fest, dass First keine Wirkung hat?
Es bleibt der Wert vom letzten Datensatz. Query.First hat keine Auswirkung...

Zitat:
Wie ist der Wert von FQuery.SQL.Text beim Eintritt in die Methode?
'select * from einstellungen'
Zitat:
Und wenn schon dynamisch per Query, warum machst du nicht gleich eine Query, die genau den gesuchten Wert holt, statt dieses "Gehampel" (zum Glück jetzt nur max. 53 Mal nachschauen und weiterschalten). Wenn es tausende Einstellungen wären, würde man wahrscheinlich gar nicht ert auf die Idee kommen, jeden lokal abzurufen und nachzuschauen, ob es die Einstellung ist, die man eigentlich braucht.

Query.sql.add("where <spalte> = :Einstellung")
Ergebnis: Leere Menge = Einstellung gibt's nicht in <spalte> bzw. Tippfehler im Parameter
Ergebnis: Ein Datensatz = Treffer
Ergebnis: Mehr = nicht eindeutig... > Fehler im Datenmodell
Ich wollte nach Möglichkeit nicht ständig eine Abfrage auf der Datenbank machen...

Ich weiß nicht warum Query.First keinen Effekt hat. Bislang hatte ich die Wert in ein Array geladen, da funktionierte es natürlich. Aber das musste ich aus einem anderen Grund ändern.

So scheint es aber auch zu funktionieren... Ich nach dem Hinweis mit Locate, loacate den Datensatz mit der procedure Query.locate und nehme dann den Wert aus der Spalte 'Spalte'... Anders herum gedacht, sieht aber ganz gut aus und ist sogar einfacher...
Delphi-Quellcode:
function TMySQLDB.Find_Property(Einstellung, Spalte: string): string;
begin
   Result:='';
   FQuery_Einstellungen.Locate('einstellung',einstellung,[]);
   if FQuery_Einstellungen.FieldByName('Einstellung').AsString=Einstellung then begin
      Result:=FQuery_Einstellungen.FieldByName(Spalte).AsString;
   end;
end;
Vielen Dank
Patrick
Patrick

Geändert von Ykcim ( 1. Mär 2019 um 10:46 Uhr)
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.165 Beiträge
 
Delphi 10.1 Berlin Professional
 
#15

AW: Query springt nicht zum ersten Datensatz

  Alt 1. Mär 2019, 10:47
Zitat:
Ich weiß nicht warum Query.First keinen Effekt hat
...weil du die Posts nicht gelesen hast.

PS: [meine Meinung]Von Locate rate ich ab. Funktioniert mal, mal nicht.[/meine Meinung]
  Mit Zitat antworten Zitat
Ykcim

Registriert seit: 29. Dez 2006
Ort: NRW
639 Beiträge
 
Delphi XE5 Professional
 
#16

AW: Query springt nicht zum ersten Datensatz

  Alt 1. Mär 2019, 11:02
Zitat:
...weil du die Posts nicht gelesen hast.
Sorry, den hatte ich tatsächlich übersehen! Damit klappt es...

Vielen Dank
Patrick
Patrick
  Mit Zitat antworten Zitat
Jumpy

Registriert seit: 9. Dez 2010
Ort: Mönchengladbach
1.552 Beiträge
 
Delphi 6 Enterprise
 
#17

AW: Query springt nicht zum ersten Datensatz

  Alt 1. Mär 2019, 11:06
Locate sollte eigentlich auch true zurückgeben, wenn der Datensatz gefunden wurde, so dass man auch schreiben kann:

if Query.Locate() then
Result:=Query.FieldByName()


@haentschman: Kannst du das mit dem Locate-Problemen konkretisieren? Sind das bestimmte Szenarien, wo das nicht geht? Benutze das recht oft (mit TADOQuery allerdings) und hatte noch keine Probleme.
Ralph
  Mit Zitat antworten Zitat
Benutzerbild von haentschman
haentschman

Registriert seit: 24. Okt 2006
Ort: Seifhennersdorf / Sachsen
4.165 Beiträge
 
Delphi 10.1 Berlin Professional
 
#18

AW: Query springt nicht zum ersten Datensatz

  Alt 1. Mär 2019, 11:15
@Jumpy:
Mein Problem: https://www.delphipraxis.net/199191-...ter-mssql.html
Probleme anderer: https://www.google.de/search?source=...19.4Maj-avE8Wc
  Mit Zitat antworten Zitat
hoika
Online

Registriert seit: 5. Jul 2006
Ort: Magdeburg
7.106 Beiträge
 
Delphi XE4 Professional
 
#19

AW: Query springt nicht zum ersten Datensatz

  Alt 1. Mär 2019, 12:01
Hallo,
Zitat:
warum machst du nicht gleich eine Query
Steht doch ganz oben.
Die Query wird als Datenspeicher benutzt und muss nur einmal ausgeführt werden.
Heiko
  Mit Zitat antworten Zitat
Benutzerbild von p80286
p80286

Registriert seit: 28. Apr 2008
Ort: Stolberg (Rhl)
6.328 Beiträge
 
Delphi 7 Personal
 
#20

AW: Query springt nicht zum ersten Datensatz

  Alt 1. Mär 2019, 12:16
Das halte ich für Sparen am falschen Ende. Meiner Meinung nach sollte der Ablauf ungefähr so sein:
Code:
Hole Parameter1
Hole Parameter2
...
Hole ParameterN
Was der TE tut ist
Code:
Hole alle vorhandenen Parameter
Hole aus der Ergebnismenge Parameter1
Hole aus der Ergebnismenge Parameter2
...
Hole aus der Ergebnismenge ParameterN
Der vom TE gewählte Weg ist erst bei einer großen Menge Parametern und/oder einer extrem langsamen DB - Anbindung effizenter.
Vor allem der Umgang mit fehlenden Werten ist im zweiten Fall aufwendiger, da es mindestens zwei Orte (DB und Ergebnismenge) gibt an denen geprüft werden muß ob die gewünschten Werte vorhanden sind.
Und das gerne genommene Select * from... kann im ungünstigen Falle so viel überflüssige Daten liefern, daß ein möglicher Performancevorteil aufgezehrt wird.

Gruß
K-H
Programme gehorchen nicht Deinen Absichten sondern Deinen Anweisungen
R.E.D retired error detector
  Mit Zitat antworten Zitat
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln

Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Gehe zu:

Impressum · AGB · Datenschutz · Nach oben
Alle Zeitangaben in WEZ +1. Es ist jetzt 12:45 Uhr.
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO © 2011, Crawlability, Inc.
Delphi-PRAXiS (c) 2002 - 2019 by Daniel R. Wolf